Piaware dump1090 issues with Pro Stick


#1

I have a working Piaware setup using a Raspberry Pi Model B and an older DVB stick. When I put a newer RTL receiver, dump1090 would work for a little bit and then crash. When I use the Pro Stick (with the ADS-B filter), dump1090 either core dumps immediately or hangs (e.g. View Live Data does not work).

The dmesg command returns the following

541.261857] usb 1-1.3: Product: RTL2838UFA
541.261875] usb 1-1.3: Manufacturer: Realtek
541.261893] usb 1-1.3: SerialNumber: 00000011
581.025594] usb 1-1.3: usbfs: usb_submit_urb returned -121

When I run dump1090 from the command line (/usr/bin/dump1090 or sudo /usr/bin/dump1090), I get the following

Found 1 device(s):
0: Realtek, RTL2838UFA, SN: 00000011 (currently selected)
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
…snip…
rtlsdr_read_reg failed with -1
rtlsdr_write_reg failed with -1
No supported tuner found
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
…snip…
rtlsdr_write_reg failed with -1
rtlsdr_write_reg failed with -1
Gain reported by device: 0.00
cb transfer status: 5, canceling…
cb transfer status: 5, canceling…

I switched out the power supply with no effect. I have a Pi 2 that I can try, but before I do that, are there any recommendations?

The working DVB stick is an Elonics E4000 tuner

1426.117472] usb 1-1.3: Product: RTL2838UHIDIR
1426.117489] usb 1-1.3: Manufacturer: Realtek


#2

Sounds a lot like power issues to me. I can’t authoritatively decipher the error messages, but anecdotally, you indicate the Pi crashes immediately with a Pro Stick (350ma demand), sorta works with the RTL (280ma demand), and works ok with the E4000 (170ma demand). Seems like you might have a power supply that is being overwhelmed as you add USB load. What are the specs on your supply (both the original one and the replacement)? Some Pi kits ship with a 1 amp supply, which will run a Pi, but croak when you start plugging in USB gizmos.

A nice clean 2 or 3 amp supply may make all the difference in your case.

Do you have any other devices plugged into USB, like an external drive or similar? If you stack up more than 600ma on the USB slots on a stock pi, your devices will drop off. On a B+ or Pi2 or better, you can deliver 1200ma across the USB slots by adding the line ‘max_usb_current=1’ to your /boot/config.txt file and rebooting. But you GOTTA have a beefy supply first or this modification will be useless. I had to do this on my Pi2 to run a 32GB SSD external drive along with my RTL stick. About 700ma total. Before the modification the RTL stick quickly died when I plugged in the external drive. All good now. I use a 5amp supply at 5vdc.


#3

I plugged the Pro Stick into a powered USB hub (and I made sure the hub did not provide back power) and got it running–mostly. Thanks for the tips.

I have noticed that after some period of time (perhaps 10 minutes), dump1090 appears to stop working. The process enters into a sleep state and does not anything (e.g. view live date, process any messages). If I do a restart, it starts up just fine. The Raspberry Pi is about 70% - 80% busy (3% piaware, 18% MLAT, 40 %- 50% dump1090), so it is not outrageously busy. This is the type of behavior I saw with the RTL. With the RTL and the Pro Stick, I am getting a substantial increase in the number of aircraft and a higher message rate. I am guessing the Pi is unable to keep up.

Given the power limitation of the original Pi (from what I understand the original Pi is limited to 1000 mA, with 500 mA for the Pi), I think it is time to retire the Pi and swap in a Pi 2 or a Pi 3.


#4

If dump1090 stops chewing CPU but keeps running, that usually means that the dongle has wedged and is no longer sending USB data. Marginal power can do that.


#5

In my case, at least, it seemed to be an overheating problem caused by the higher currewnt, rather than a PSU issue. The Prostick caused a crash within about a minute. Removing the PI B+ from its case solved this problem.

There also seems to be an issue with the web interface causing crashes, particularly at night (low traffic or internet going down?).

This is still a problem after upgradinf to a PI 3, Flightaware filter and antenna, the latest software, and the approved raspberry PI PSU.