FlightAware Discussions

Piaware-config.txt can not be autosaved

Edit: if anyone else in the future has this issue with a mac, try using xcode to save the txt file.

Had a receiver years ago, unfortunately something happened to it and it was unusable.

Just ordered new piaware-config.txt can not be autosaved and using a new computer (imac)
was able to install piaware on the sd card but for some reason when putting in my wifi credentials I keep getting a “document piaware-config.txt could not be saved”.
It is also saying the auto-save is not available.

Not really sure what is going on. There is no option to open as an admin when I open the txt file on the sd card. I even tried enabling prevent editing and reenabling it to no luck.
I did everything per PiAware - build your own ADS-B ground station for integration with FlightAware - FlightAware
also, my ssid and password don’t include anything other than letters or numbers
sd card is the one that came with the pi 3.
samsung 32g evo plus

Thanks

Update #2. xcode was able to save the file correctly and verified by seeing raspberry pi come up on my home wifi

Update: I think I was able to save it with xcode.
Though when saving xcode is saying " The document “piaware-config.txt” is on a volume that does not support permanent version storage.".
not really sure how to get around this

It may be the editor you are using. You want the dumbest, most cut down editor you can get so it doesn’t try to ‘help’.

An alternative is to enable SSH and use Nano (on the Pi) to edit the file once it has booted (obviously with a network cable plugged in)

1 Like

I agree. The last time I set my feeder up, I used Textedit on my Mac for this step. The trick was to go into the Format menu first, and set the “Make Plain Text” option. That forced it to save in UTF-8 instead of Rich Text.

Worked like a charm!

1 Like

I’m trying to add adsbexchange as well. Having such a headache!
I ended up just trying the adsbexchange image but still having an issue… UGH!
keeps saying “The file could not be unlocked” no mater what I do.

That’s not very specific as to what says it and when …

ended up downloading sublime text and worked like a charm. Not sure why xcode stopped allowing the file to be saved… oh well lol