PiAware - Can't listen MLAT


#1

Hi.
I’m trying to reconfigure MLAT to work with ModesMixer2, but I can’t make PiAware to listen on port 31003. This is the line of MLAT result afiter “piaware-config -show”


mlatResultsFormat {beast,connect,localhost:30104 ext_basestation,listen,30106 beast,listen,31003}

Alread done “services piaware restart”, but no listening


root@rtl:/etc/init.d# netstat --listen
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State
tcp        0      0 *:30015                 *:*                     LISTEN
tcp        0      0 *:8000                  *:*                     LISTEN
tcp        0      0 *:8001                  *:*                     LISTEN
tcp        0      0 *:8002                  *:*                     LISTEN
tcp        0      0 *:39076                 *:*                     LISTEN
tcp        0      0 *:8012                  *:*                     LISTEN
tcp        0      0 *:1234                  *:*                     LISTEN
tcp        0      0 *:8754                  *:*                     LISTEN
tcp        0      0 *:ssh                   *:*                     LISTEN
tcp        0      0 *:8022                  *:*                     LISTEN
tcp        0      0 *:30104                 *:*                     LISTEN
tcp        0      0 *:30011                 *:*                     LISTEN
tcp        0      0 *:30013                 *:*                     LISTEN
tcp        0      0 *:30014                 *:*                     LISTEN
udp        0      0 *:5683                  *:*
udp        0      0 192.168.22.107:ntp      *:*
udp        0      0 localhost:ntp           *:*
udp        0      0 *:ntp                   *:*
udp        0      0 *:55453                 *:*


What am I doing wrong?


#2

What does /tmp/piaware.out say? It will log the exact command line that mlat-client is started with. Given that neither listen port is bound, I’d say that mlat-client failed to start (or mlat is not enabled)


#3

01/28/2016 17:45:53 ****************************************************
01/28/2016 17:45:53 piaware version 2.1-5 is running, process ID 1582
01/28/2016 17:45:53 your system info is: Linux rtl.jonis.com.br 4.1.13-v7+ #826 SMP PREEMPT Fri Nov 13 20:19:03 GMT 2015 armv7l GNU/Linux
01/28/2016 17:45:53 Connecting to FlightAware adept server at piaware.flightaware.com/1200
01/28/2016 17:45:53 ADS-B data program 'modesmixer2' is listening on port 30005, so far so good
01/28/2016 17:45:53 Starting faup1090: /usr/lib/piaware/helpers/faup1090 --net-bo-ipaddr localhost --net-bo-port 30005 --stdout --lat -21.171 --lon -47.821
01/28/2016 17:45:53 Started faup1090 (pid 1618) to connect to modesmixer2
01/28/2016 17:45:53 Connection with adept server at piaware.flightaware.com/1200 established
01/28/2016 17:45:54 FlightAware server SSL certificate validated
01/28/2016 17:45:54 encrypted session established with FlightAware
01/28/2016 17:45:54 autoUpdate in adept config is enabled, allowing update
01/28/2016 17:45:54 manualUpdate in adept config is enabled, allowing update
01/28/2016 17:45:54 multilateration support enabled (use piaware-config to disable)
01/28/2016 17:45:54 piaware received a message from modesmixer2!
01/28/2016 17:45:54 logged in to FlightAware as user jmaurin
01/28/2016 17:46:18 piaware has successfully sent several msgs to FlightAware!
01/28/2016 17:46:23 9 msgs recv'd from modesmixer2; 8 msgs sent to FlightAware
01/28/2016 17:51:23 90 msgs recv'd from modesmixer2 (81 in last 5m); 89 msgs sent to FlightAware
01/28/2016 17:55:28 lost connection to modesmixer2 via faup1090
01/28/2016 17:55:28 reconnecting to modesmixer2
01/28/2016 17:55:28 no ADS-B data program seen listening on port 30005 for 0 seconds, next check in 60s
01/28/2016 17:56:23 202 msgs recv'd from modesmixer2 (112 in last 5m); 201 msgs sent to FlightAware



root@rtl:/tmp# piaware-config -show
contents of piaware config file '/root/.piaware':
autoUpdate 1
manualUpdate 1
mlat 1
mlatResults 1
mlatResultsFormat {beast,connect,localhost:30104 beast,listen,31003}
password XXXXX
user jmaurin



root@rtl:/tmp# netstat --listen
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State
tcp        0      0 *:30015                 *:*                     LISTEN
tcp        0      0 *:8000                  *:*                     LISTEN
tcp        0      0 *:8001                  *:*                     LISTEN
tcp        0      0 *:8002                  *:*                     LISTEN
tcp        0      0 *:8012                  *:*                     LISTEN
tcp        0      0 *:55885                 *:*                     LISTEN
tcp        0      0 *:8754                  *:*                     LISTEN
tcp        0      0 *:1234                  *:*                     LISTEN
tcp        0      0 *:30005                 *:*                     LISTEN
tcp        0      0 *:ssh                   *:*                     LISTEN
tcp        0      0 *:8022                  *:*                     LISTEN
tcp        0      0 *:30104                 *:*                     LISTEN
tcp        0      0 *:30011                 *:*                     LISTEN
tcp        0      0 *:30013                 *:*                     LISTEN
tcp        0      0 *:30014                 *:*                     LISTEN
udp        0      0 *:46630                 *:*
udp        0      0 *:5683                  *:*
udp        0      0 192.168.22.107:ntp      *:*
udp        0      0 localhost:ntp           *:*
udp        0      0 *:ntp                   *:*
Active UNIX domain sockets (only servers)
Proto RefCnt Flags       Type       State         I-Node   Path
unix  2       ACC ]     STREAM     LISTENING     5202     /run/systemd/private
unix  2       ACC ]     SEQPACKET  LISTENING     5224     /run/udev/control
unix  2       ACC ]     STREAM     LISTENING     5228     /run/systemd/journal/stdout
unix  2       ACC ]     STREAM     LISTENING     8866     /run/user/0/systemd/private
unix  2       ACC ]     STREAM     LISTENING     7608     /var/run/dbus/system_bus_socket
root@rtl:/tmp#



#4

Well, you have no input source (modesmixer is not running), piaware isn’t going to start mlat-client until something is providing data.

(also that netstat output doesn’t match what piaware is seeing, FWIW)


#5

(looks at the site page) You haven’t manually set a position; you must do that before mlat will start. Did mlat ever work for you before this?


#6

About ModesMixer, it’s running. This logs is before I started ModesMixer. About worked before, never. Where do I set location? I have location set in my ModsMixer2 and in my site in Flightaware, nothing else. As I can see, piaware is not even trying to start fa-mlat-client


#7

You need to set the location at flightaware.com/adsb/stats/user/jmaurin. I see you’ve just done that now; if you restart piaware it should pick up the change.


#8

Yep, I’ve set before…but for some reason, didn’t worked. Now I can see mlat is starting, but still not data :frowning:

This is my setup now:
ModeSDeco2 is running to get ADS-B and MLAT data, and listening on port 30014 for MLAT, 30011 for SBS1001, 30013 for MSG and 30015 for BEAST. This is the command line:


PROG_ARGS="--device-serial 11 --location -21.1709137498238:-47.8212995529175 --freq-correction 71 --web 8012 --avrmlat 30014 --sbs10001 30011 --msg 30013 --gain 43.9 --beast 30015 --metric --filter-nocountry --flight-expire-time 1800"

ModeSmixer is running with these parameters:


PROG_ARGS="--metric --location -21.1709137498238:-47.8212995529175 --web 8002 --silhouettes /server/silhouettes/ --pictures /server/operators/ --db /server/BaseStation.sqb --frdb /server/flightroute.sqb --filter-nocountry --flight-expire-time 1800 --inConnect localhost:30015 --inServer 30104 --outServer beast:30005 --inConnect localhost:30014"

This tells mixer to connect to modesdeco2 on port 30015 to get ADSB data, connect to modesdeco2 on port 30014 (should be MLAT data), listen on port 30005 as a server and send BEAST data.

And this is the current configuration for piaware:


root@rtl:~# piaware-config -show
contents of piaware config file '/root/.piaware':
autoUpdate 1
manualUpdate 1
mlat 1
mlatResults 1
mlatResultsFormat default
password XXXX
user jmaurin


What am I missing?


#9

It looks like it is starting up

Feeder Type: PiAware (Debian Package Add-on) 2.1-5
Multilateration (MLAT): Supported / Enabled (synchronized with 1 nearby receivers)

Nearest Airport: Leite Lopes (Ribeirao Preto, Sao Paulo) (SBRP / RAO) - Brazil


#10

Yep, now it’s starting. But I couldn’t see any MLAT message (counter = 0) in my flightaware statistics page :frowning:

Ond more info:


01/28/2016 19:43:53 mlat(9207): Receiver status: connected
01/28/2016 19:43:53 mlat(9207): Server status:   synchronized with 1 nearby receivers
01/28/2016 19:43:53 mlat(9207): Receiver:   33.3 msg/s received      0.7kB/s from receiver
01/28/2016 19:43:53 mlat(9207): Server:      0.0 kB/s from server    0.0kB/s TCP to server   0.1kB/s UDP to server
01/28/2016 19:43:53 mlat(9207): Aircraft: 3 of 6 Mode S, 2 of 8 ADS-B used



#11

You also need 3-4 other active MLAT receivers nearby.

I looked at your location and don’t see many close to you(The map doesn’t have a scale so it is hard to work out).

Looking at your excellent reception range, I expect that you should get some MLAT hits on a daily basis.
Your busiest time seems to be around 11AM local. Maybe check then.


#12

Good to know :slight_smile:
Right now it’s 5:58 PM


#13

About my range, I’m kind happy with that. I’m just little sad with Flightaware…I’ve asked for FlightFeeder, but I’ve got no as answer…There are smaller cities near me that have Feeder, but doesn’t cover my Area. I know that there’s one user very, very close to my location with FlightFedder…it’s in Sertãozinho, about 20km from here. But this users rarely is online…most of time, offline, like now.
My range is with and homemade antenna (franklin) and homemade LNA + filter for 1090Mhz. I asked for FlightFeeder because I think I can make a better range with ‘professional’ antenna and receiver.


#14

The Flightfeeders are nicely packaged and come with a well built antenna but looks are not everything.
The Piaware systems and homemade antennas can be equal or better than the FlightFeeder in performance. And, they also support MLAT while the FlightFeeders do not.

You need to get some friends in your area to add Piaware setups and share data links. Then you will have both greater range and MLAT coverage.


#15

Jonis,

There are a couple of flight feeders listed around you.
When they get the uprgaded to do MLAT it will help your MLAT stats considerably.

I just saw you have several MLAT position reports and one aircraft.

Good luck.


#16

Yep, just saw this too! tks :smiley: