PiAware 7 SD Card Image Released

Yeah, this is unusual. What’s the hardware?

(It looks almost like you have intermittent very loud interference)

So, I’ve ran it a while and it looks like the gain is still jumping around. Sometimes at Gain Step 11, and others times, like this dump, with Gain Step 3. Not sure if I’m looking at the wrong value. Regarding interference, this receiver is on a mountain top in a radio site. While this particular site doesn’t have any 900MHz equipment, I not sure what is in the county radio site 1/4mile away. Although the county doesn’t use any 900MHz frequencies, other government agencies might also be in there. Could also be poor CATV / Internet equipment which also goes through the site.

Here is the latest gain dump:

– Journal begins at Wed 2022-01-12 19:03:21 UTC, ends at Sat 2022-02-05 19:36:00 UTC. –
Feb 05 19:11:14 piaware dump1090-fa[6086]: rtlsdr: tuner gain set to 7.7 dB (gain step 5)
Feb 05 19:11:24 piaware dump1090-fa[6086]: adaptive: available dynamic range (36.2dB) >= required dynamic range (30.0dB), stopping downwards scan here
Feb 05 19:21:14 piaware dump1090-fa[6086]: adaptive: available dynamic range (22.7dB) + half gain step down (30.0dB) < required dynamic range (4.0dB), starting downward scan
Feb 05 19:21:14 piaware dump1090-fa[6086]: adaptive: changing gain from 7.7dB (step 5) to 3.7dB (step 4) because: dynamic range fell below target value
Feb 05 19:21:14 piaware dump1090-fa[6086]: rtlsdr: tuner gain set to 3.7 dB (gain step 4)
Feb 05 19:21:24 piaware dump1090-fa[6086]: adaptive: available dynamic range (38.3dB) >= required dynamic range (30.0dB), stopping downwards scan here
Feb 05 19:31:14 piaware dump1090-fa[6086]: adaptive: available dynamic range (25.4dB) + half gain step down (30.0dB) < required dynamic range (1.0dB), starting downward scan
Feb 05 19:31:14 piaware dump1090-fa[6086]: adaptive: changing gain from 3.7dB (step 4) to 2.7dB (step 3) because: dynamic range fell below target value
Feb 05 19:31:14 piaware dump1090-fa[6086]: rtlsdr: tuner gain set to 2.7 dB (gain step 3)
Feb 05 19:31:24 piaware dump1090-fa[6086]: adaptive: available dynamic range (39.9dB) >= required dynamic range (30.0dB), stopping downwards scan here

 

Do you have a filter connected between Antenna and the Dongle?
If not, better connect one.

 

For 1090 MHz Only (narrow-band)

 

For 1090 and 978 MHz (wide-band)

1 Like

 

Till you get and install a filter, put a lower limit to adaptive gain

sudo piaware-config adaptive-min-gain 30   

sudo systemctl restart piaware   

Now check/confirm minimum gain has been set to 30 dB

sudo piaware-config -show adaptive-min-gain   

After 10 minutes check logs

sudo journalctl -u dump1090-fa -n 10   

 

I am using the FlightAware Pro Stick Plus for my receiver. I was under the impression it had all the filtering I needed. BTW, it’s not a case of the receiver not working at the site, it’a about the receiver not working as well as it did before I upgraded the OS and feeder application. It was working rather well, at least that is what I thought, comparing my data collection compared to nearby stations.

I think I want to let it run for at least 24 hours to allow the data to smooth out. I’ll go ahead and change the min gain but like I said earlier, none of this happened until I updated the software.

Eric

I live in an urban high-rise area with all sorts of RF noise (FM, TV VHF, UHF, Cell phones etc). In RF noisy conditions like mine and many others, the internal filter of ProStick Plus is not enough, and an external filter is required.

Please see this post where I have posted results of RF Scan at my location without and with external filter. This scan covers the full frequency range of the dongle (24 MHz ~ 1800 MHz).

https://discussions.flightaware.com/t/signal-level-randomly-changing/80309/7

 

 

Since the major change in software is addition of “Adaptive Gain Control”, first disable it, then monitor for 24 hrs. Afte that, you can enable adaptive gain control and again monitor for 24 hrs

sudo piaware-config adaptive-dynamic-range no  

sudo systemctl restart piaware   

sudo systemctl restart dump1090-fa   

NOTE: After disabling “adaptive gain control” by 1st command above, you must either reboot Pi or restart both piaware and dump1090-fa for the change to be implemented

After 10 minutes check logs

sudo journalctl -u dump1090-fa -n 10   

 

1 Like

I need additional filtering here. The internal filter in the ProStick Plus is not enough here.
See this earlier post from a few years ago:

1 Like

Before I make any hardware changes, I wanted to share 2 screen shots. One is the mountain top site that, prior to Monday, has an awesome coverage area but, since installing SkyAware 7.1, sucks. The second image is at my house about 10 miles away and 1200’ lower in elevation which historically received a couple hundred less aircraft a day.

As you can see, something isn’t right with the configuration. Maybe I should hose the other 2 feeders and see if that changes anything???

Thanks,
Eric

OK, uninstall other two feeders and observe the performance. It will clear if the cause of problem is those feeders or something else.

What are the commands/routines I should use to remove FR24 and PlaneFinder from the system (or would I be better in building a new, clean image)?

What version did you upgrade from?
Was it version 6 or something older?
Auto gain was introduced in version 6 so, if the problem might be caused by the auto gain feature , if you have local interference that is triggering it. If your previous version was Version 5 or older it would have been operating with a fixed gain.

1 Like

Uninstall/purge

sudo apt-get purge fr24feed   

sudo dpkg --purge pfclient   

sudo reboot   

 

Check

sudo systemctl status fr24feed   

sudo systemctl status pfclient   

apt-cache policy fr24feed   

apt-cache policy pfclient   

 

1 Like

Look at their websites and see if there are removal instructions. If not, reverse-engineer the installation instructions. For example if to install it they say to add a repository then do sudo apt install, then do a sudo apt remove then remove the repo. If none of that works check their support forums or ask there.

Or, since you’ve only recently installed PiAware 7 anyway, it would be just as easy to reburn the image to the SD card and start over, unless that would entail trips to several feeder locations to do.

As the problems that are happening have only cropped up since you burned PA 7 to the SD cards I’m wondering if you may have a bad burn? Highly possible if you used Etcher instead of the recommended tool in the instructions. Or if these feeders have been in existence for a long time maybe the SD cards are bad?

You’re using Pi power supplies, right? Not spare cell phone chargers?

@estruble rebuilt it with ver 7.1 after his 4 years old built crashed.

I feel @obj 's conclusion is that is what is happenning.

His old build was at default setting (--gain -10). With short bursts of strong interference, his receiver saturated, reception fell to low, but remained low only during the short duration of burst, and recovered to high when the short burst stopped. His overall number of aircraft per day remained high.

With adaptive gain control, when the short bust of interference starts, gain is set to zero, and stays at zero even when the burst is gone. It recovers only when next cycle of adaptive gain starts. This repeats everytime there is a burst. This results in longer duration of zero reception, and consequently lower number of aircraft per day compared to old non-adaptive install.

This is the reason I advised him to turn-off adaptive gain, so his current install becomes like his old install, but he seems to believe that the cause of reduced reception are FR24 and Planefinder feeders, and not the adaptive gain control triggered by short bursts of interference.

I also suggested him to install external filter but he thinks FA Pro Plus’s builtin filter should be enough.

Upon his request I have posted commands to purge both these feeders. He will now remove these two feeders and observe the performance for for next 24 hrs after removal of feeders. Let us wait and see the outcome.

1 Like

Set a fixed gain … it’s pretty clear autogain isn’t doing what it should.

2 Likes

As it was working before i doubt that a missing filter now is the problem.
It can happen if new interferring stations are built around, but i think this is not his issue.

1 Like

 

That is what I have advised him.

 

I think that the point was that a filter might dampen the interference, which may allow autogain to work as it is supposed to.

That said, autogain routinely set my gain lower than the value that I had previously determined worked best for my location, and for several weeks my messages, aircraft, and distance measurements were 15%-20% lower than what I was used to. I turned off autogain and went back to the gain value that got me to ~5% strong messages, and everything came back in line.

The unfortunate thing is that @estruble is very strongly convinced that since FR24 and Planefinder feeders are new things in current install (his old install did not have these), these have caused the reduction in performance. He wants to uninstall them and is pretty sure that this will restore his performance to original.

Yes, you are right. That is exactly why I suggested adding an external filter to ProStickPlus.