PiAware 1.16 Released


#1

PiAware 1.16 Released – here’s the change log:

  • Reworked problem detection and restart logic: Piaware will now reliably attempt to restart dump1090 if no messages are received in an hour and piaware can find a startup script for dump1090 in /etc/init.d to restart it with.

  • Piaware will now attempt to start dump1090 if no ADS-B producer program is seen listening for connections on port 30005 (the “Beast” binary data port) for more than six minutes.

  • Most piaware messages logged locally are now also forwarded to FlightAware. This will greatly help with debugging and users will soon be able to retrieve the last few hours of log messages via the FlightAware website.

  • New remote update capability for updating Raspbian and piaware. Automatic and manual updates are supported. Both can be enabled or disabled on the device using piaware-config and auto updates can be disabled by the user through the FlightAware website. If enabled the user will be able to issue manual updates through the FlightAware website, updating PiAware, other Debian packages, and the operating system and boot firmware as well as rebooting and restarting piaware and dump1090.

  • If the connection is lost with the FlightAware server then the reconnect interval is randomized between 60 and 120 seconds rather than hard-set at 60 seconds to ease the server load when the adept server is restarted and a thousand plus piaware hosts all reconnect at the same time

PiAware for SD Card
PiAware Add-On (for Linux users)


#2

Ummm… hasn’t 1.16 been out since the beginning of the month?


#3

The add-on package, yes. The SD Card full image was just released from beta today.


#4

Can I juzt put the new image on my existing SD card? Don’t have a monitor for my Pi yet!


#5

Yes, no configuration necessary.


#6

I’m not very Linux savvy and I just upgraded the Disk Image to 1.16. Now, when I boot my Pi, my display (DVI via the HDMI port) states that it ‘Doesn’t support this display mode’. This didn’t happen with the disk images for 1.13, 1.14, or 1.15.

I tried to change some of the config.txt file options but nothing is working so far.

What has changed on the Linux image on 1.16 that would not work with my display?

Thanks.

Jon


#7

Not that much. Can you try re-writing the image?


#8

No Joy after re-writing the image. Still get:

Cannot Display This Video Mode - Optimum resolution 1280x1024 60Hz from my monitor

PiAware and Dump1090 are running (monitor not working, but I can access the Web display for Dump1090).

I’ve updated PiAware to 1.16 using WGET onto the 1.15 image and that works fine. Something is different on the 1.16 Linux image??

Thanks


#9

Assuming the image is mostly vanilla Raspbian, take a look in /boot/config.txt, some monitor/cable combinations can need tweaking here.

e.g. I use:

disable_overscan=1
hdmi_force_hotplug=1
framebuffer_width=1280
framebuffer_height=720
gpu_mem=16

(Edit: oops, I see you already found those settings!)


#10

There was an “innocuous” change in the 1.16 image build related to video display…

I had found it somewhat frustrating with the Raspberry Pi that if you boot it up without an HDMI display plugged in and turned on, if you later plug in an HDMI display then it won’t work. You had to reboot for it to recognize the display.

The change was to add “hdmi_force_hotplug=1” to /boot/config.txt, which makes the Raspberry Pi pretend that the HDMI hotplug signal is asserted so it will “see” a HDMI display is attached even when one isn’t.

This is probably your problem: We also added “hdmi_drive=2” to set “normal HDMI mode”. Thanks for the hint that you’re using DVI because hdmi_drive=1 sets normal DVI mode. So I think the hdmi_drive=2 broke your DVI.

I am about to board an aircraft but I am planning to roll up a 1.17 PiAware SD card image when I arrive back in Houston in several hours. I’ll take the hdmi_drive=2 out. If you can ssh into your Pi over the network then you can edit /boot/config.txt and reboot. Alternatively since the /boot/config.txt file is on the FAT32 partition on the SD card if you have a PC or a Mac and a USB-MicroSD adapter or something then there’s a pretty decent chance you’ll be able to see the config.txt file without having to mount it on a Linux system (since PCs and Macs understand FAT32) and edit it from your computer. Or just wait a bit and grab the new image.

Sorry for the difficulty. Thanks for the thorough report that made this problem easier to solve than a lot of them! -karl


#11

Hi, it took a little longer than expected due to a slow upload problem from my place, but I’ve got the piaware SD card image for 1.17 ready for people to try. It’s at piaware.flightcdn.com/piaware-sd … 17.img.zip and it should prevent the runaway piaware problem that fills /tmp with log messages, so please try it and let us know. Thanks.


#12

What are the steps for disabling auto updates? I’m not keen on auto updates, nor any remote access configurations. I can’t find any reference on the web site to disable auto updates. The man page for piaware-config only shows the following options:

 -user FlightAware_UserName
         Specifies the user name or email address of the FlightAware
         account piaware will login as
 -password
         piaware-config will request the password interactively.
 -start  Attempts to start piaware.  (This is a synonym for
         /etc/init.d/piaware start)
 -stop   Attempts to stop piaware.
 -restart
         Attempts to restart piaware.
 -status
         Emit a brief report on the status of piaware.
 -help   Emit a brief summary of piaware usage options.

Thanks!


#13

Did you install the debian package or our full SD card image? If the package, then it’s disabled by default.


#14

I used the SD card image available on this web site. I expected it to be a standard install plus dump1090/piaware?


#15

Yes, the reason I asked is because the defaults are different.



raspberrypi:/home/dbaker% piaware-config 
usage: piaware-config -help|-user|-password|-start|-stop|-status|-autoUpdate 1/0|-manualUpdate 1/0
raspberrypi:/home/dbaker% 


You can just run:



sudo piaware-config -autoUpdate 0



#16

Mine must be a different version…
When attempting, I’m getting:

pi@piaware ~ $ sudo piaware-config -autoUpdate 0
piaware-config : piaware-config -help|-user|-password|-start|-stop|-status ?args?
-user value specify the user name of a valid FlightAware account <>
-password interactively specify the password of the FlightAware account
-start attempt to start the ADS-B client
-stop attempt to stop the ADS-B client
-restart attempt to restart the ADS-B client
-status get the status of the ADS-B client
– Forcibly stop option processing
-help Print this message
-? Print this message

pi@piaware ~ $

This implies it didn’t know what to do with the argument…


#17

Yes, auto-update is only supported in 1.16 and above, which is what posters in this 1.16 announcement thread are referring to – you must be running 1.15 or earlier.