FlightAware Discussions

Pi Needs Restart Every Couple Days

Every couple days I notice that errors start occurring with dump 1090 or MLAT etc. I have not had time to figure out how to check logs etc so I reboot and that gets things going again for another couple days. Is there some auto restart code that I can implement maybe every day to ward off any errors?

You need to describe the problem you see properly.

If nothing else has changed with your setup to cause the problem, try swapping the PSU.

1 Like

I have a similar problem where i did not find a solution so far.

My RPi 4 intermittenly loses the network connection. It can happen 2-3 times a day, or it can run for several days. After reading lots of sources i decided to ignore the root cause problem and added a script which pings my router every minute. If not available it is restarting network. If this fails as well, a full reboot is performed.

I am using the original power supply from Raspberry for this device. It does not do anything else than flight tracking.

I have a Pi 3. I’m using the power supply that came with it. The pi only runs this stuff and the power supply only powers the pi and the receiver. The receiver is plugged directly into the pi. The setup seems to behave better once I installed 3.8.1. However every couple days it starts to act up. I do a restart and it’s good for another three or four days.

Strange, my second device is a RPi 3B also doing nothing than tracking. Stick is connected directly.

Current uptime: 62 days

Found a thread on GitHub which explain the problems with BCM firmware.
Followed the instructions and replaced brcmfmac43430-sdio and brcmfmac43455-sdio which solved the problem for users there.

Testing now…

Interesting… awaiting your results… what is BCM ? something control module?

BRCM is the abbreviation for Broadcom… I missed the R in my previous post. Sorry :frowning:

So far no lost connections today after the installation this morning.

BCM is correct, at least when talkig about their different chips, like BCM2711 is the newest SoC for the Raspberry Pi :slight_smile:

1 Like

That really drives me nuts…Thanks for clarification

Is this the link?

So this is somewhat of a known issue? It seems that nearly half of the time I reboot my system it never comes back up, and I always thought it was just a corrupted memory card because reflashing always fixed it.

I guess I need to get myself a remote way to cycle the power as well if it’s a total gamble whether or not the network connection works after a reboot.

What’s the thread?

Generally the firmware originates from the Pi Foundation, so you’ll get firmware updates as a matter of course in Raspbian updates anyway…

Sorry, did not post it here, will try to find it again. The firmware was slightly newer than the original files.

However this morning the device lost connection again twice and rebooted.
What i still need to check if the device lost connection completely or only to the internet as i was pinging one of the google nameservers.
Changed this now to my router IP and will monitor it.

Will post the link later

Got it here: https://github.com/raspberrypi/linux/issues/2453

In the last comment there are the links to the FW files, i used this one:

https://community.cypress.com/docs/DOC-19375

My setup (pi) ran for 6 days without a problem. Yesterday it went down 2x. I didn’t screenshot the error but was saying something about ajax and that possibly dump 1090 wasn’t running or dumping or outputting or something. A restart of the pi and we were back in business. I know that the power didn’t go down or glitch. Not sure about the WiFi. Next time I will try to get more and better info on what might have happened or what the status was.

Have you tried a different PSU?

No. I guess I will have to dig up another to try. Are the supplies that are provided problematic or suspect?

No. The foundation supplied PSU’s seem to be amongst the most reliable (cheap phone chargers are the worst), but a soft PSU matches your symptoms.