Pi-3 has 2 IP addresses, stops sending data


#1

I am having issues with a new R-Pi 3 running the new Jessie 2.15 image. It came up OK on Ethernet, and I let it sit there for a couple of days to get a baseline feel for air traffic. I then enabled WiFi by editing the wpa_supplicant file, and got an IP address for wlan0 – all good so far. After less than a day, I realize it is offline and producing no data, so I have re-connected it to Ethernet.

Now I have two questions: [1] how do I set i up to reconnect if it loses WIFI? I’ve seen a post directing a user to here [flightaware.com/adsb/piaware/build/optional#wifi], but see no instructions on how do set up WIFI reconnect. Maybe the page has been changed recently… Any suggestions on how to do this?

[2] While plugged into the Ethernet, I am now getting two IP addresses. I can see the same aircraft plotting on both pages locally… I would prefer to have the WIFI turn on only if eht0 is not connected – is there a way to do that?

FWIW, this does not appear to be a network issue, as other computers are working fine, including my other Piaware server [R-Pi2, WiFi only], which has sat there delivering data consistently through all this.


#2

It should reconnect automatically.

If it doesn’t, can you mail me your syslog while it is in the broken state.

[2] While plugged into the Ethernet, I am now getting two IP addresses. I can see the same aircraft plotting on both pages locally… I would prefer to have the WIFI turn on only if eht0 is not connected – is there a way to do that?

The Raspbian default is actually to do as you describe, but it makes it somewhat confusing when transitioning from wired to wireless so the piaware image disables it.
You can restore it by creating a symlink from /etc/ifplugd/action.d/action_wpa to /etc/wpa_supplicant/action_wpa.sh


#3

Thanks for the help!

[1] I will keep an eye on it, and will send a log file if the problem recurs.

[2] Is it safe to assume we intend to force the symlink to replace the existing file? I’m using the following:

sudo ln --symbolic /etc/wpa_supplicant.sh /etc/ifplugd/action.d/action_wpa, and get back:

ln: failed to create symbolic link “/etc/ifplugd/action_wpa”: File exists

Thanks…


#4

Oh, sorry, I am guilty of skimming your post and not reading it properly. My instructions (including the “it should reconnect automatically”) are for the PiAware 3.0.4 image, not the older 2.1-5 image. If you’re doing wifi on 2.1-5 then yes you will have to mess around with the wifi settings yourself and probably arrange for it to reconnect. If you’re not particularly attached to the old image, try the new image?


#5

This is my ‘experimenting’ machine, so I am open to trying the new image. I will take a look…

Which raises the question: If the new image works well for me on this R-Pi 3, will it also be appropriate for an older R-Pi 2?

EDIT: I downloaded and booted from the new 3.0.4 image, and have the following to report:

  • The new image automatically launches ‘x’ and the gui…
  • The gui reports that dhcpd is not running
  • WIFI appears to not be enabled
  • The gui presents no way to turn on WIFI
  • If necessary, I CAN get an Ethernet cable to this machine and manually set up WIFI. Where are the settings now?

Thanks again,


#6

See flightaware.com/adsb/piaware/bu … ional#wifi


#7

Thanks. I looked at the link, and followed the instructions for editing the .txt file.

While the machine did come up on the network, the other machine went down right at that point. I will spend some time today sorting that out. Hopefully it was just a coincidence. It’s also possible I made a mistake, as I did have ssl sessions going for both machines, but I’d be surprised.

Is it safe to assume this approach will also work for the older versions of the software, running on older R-Pi hardware?


#8

The PiAware 3 image will run fine on older hardware. You may be short on CPU on a B or B+, but that’s true regardless…
The wifi setup instructions I linked are for PiAware 3 only, not for older software versions.


#9

OK, thanks. I think I have what I need to proceed.