No Flight Tracking Maps - Chrome

I have recently noticed whenever I load a particular flight or load an airports activity, that I cannot view the tracking map at all. The space is just white and is not still loading. I am having this issue with Chrome, checked using IE7 and it worked like it should. Anyone else having this problem? Solutions? Thanks.

Are you running release (3.x) or beta (4.x)?

I am running beta 4.0x, but it is odd because it just started doing this a few weeks ago.

I use Chrome 3.0 and maps are working fine here, although they were down last weekend.

I had the same problem with Chrome and Firefox. Apparently it had something to do with the default browser and popup blockers and I don’t know what else. This is what I did to correct the problem. First, open FA in Internet Explorer. Then go up to address bar and right click and copy address. Next, open Chrome to a blank page, move cursor to address bar and right click and paste the address into the space and press enter. That fixed it for me. Worked fine ever since. Can’t explain why but it did. Good luck.

Well I tried what you said about pasting in the URL, but it still didn’t work for me. I can see the ring moving in chrome, so I know that it is updating the map, but just not displaying it.

Switch to release 3.x; the beta version breaks frequently.

This is unlikely to solve the problem. Not sure what it did for you.

I can’t explain it either but it works.

No go for Firefox 3.5.5 (Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv: Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)). Here’s what my tracking pages look like…

And IE 8 (IE 8.0.7100) gives this on every FlightAware page with a track on it…

Maps have packed up in Opera now as well. Some flights are showing but the dots are not moving and is also showing dots in the air that have landed over 24hrs ago. Other dots are not showing on the map at all despite being in flight cruise (and no they are not blocked flts as they show in the airport arr/dep listings). Enroute dots have also stopped showing on 2 stages of zoom-out on the maps, whereas they were all working fine 2 days ago.

The coastline outline is also broken and no longer shows for past 24hrs as well. According to the map all the mainland US airports are now in the middle of the sea :open_mouth: . That is for the small map and the enlarged map too.

:unamused: :confused:

The problem has mysteriously fixed its self :question: :question:

Woke up this morning and things were back to normal. Thanks for the great website, FlightAware!

We had some issues overnight with the background images and weather overlays. Should be back to normal now.

Well people are saying that is fixed now, but I still have a white background where the map should be.

Dots are now working okay but there’s still no coastline on any of the maps. :angry:

Coastline now showing ok again and airports back on land instead of middle of sea. :laughing: