FlightAware Discussions

No data received from the SDR for a long time

Hi,

I have two pi-aware boxes and the 2nd started showing outages over New Years.
I did a clean install (i.e new Raspbian and Piaware package install) but continue to get syslog entries like:

Jan 2 13:30:48 piaware02 dump1090-fa[977]: Wed Jan 2 13:30:48 2019 CET No data received from the SDR for a long time, it may have wedged

I tried to the recommendation in the topic “Is My DVB-T / Pro Stick / RTL SDR Dongle OK?

but the output looks of (per the thread):
pi@piaware02:/var/log $ rtl_test -t
Found 1 device(s):
0: Realtek, RTL2832U, SN: 00001000

Using device 0: Generic RTL2832U
Found Rafael Micro R820T tuner
Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
[R82XX] PLL not locked!
Sampling at 2048000 S/s.
No E4000 tuner found, aborting.

Any help greatly appreciated !

Try connecting the SDR to an external powered USB hub. I have had issues with the sticks connected directly to the Pi. This also gives me the ability to run 2 SDR sticks so I can get the older dump978 data if I chose to turn it on.

Pretty well exactly what happens when the PSU goes soft
As it’s an easy thing to test, try swapping the PSU between your two Pis and see if the problem follows the PSU.

Thank you both for your replies.

The power supplies are original Pi foundation ones and the SDRs are “FlightAware Pro Stick Plus”, so i was a little sceptical of either one breaking and suspected a software issue.

However, now after swapping power supplies and SDRs each one after the other, the problem seems to be with the 2nd SDR stick.

As i said i tried to verify if that stick is ok and it passed the test.
Are there other tests i can use to see if the stick is (irreparably) broken…?

Thanks !