FlightAware Discussions

NO_DATA error when using GetFlightTrack

Hi all,
I’m trying to retrieve a flight route for a flight in the recent past.
https://flightxml.flightaware.com/json/FlightXML3/GetFlightTrack?ident=NAX7041-1551594354-airline-0347&include_position_estimates=true

But I get a NO_DATA error. Are there limitations as to which flights we can get flight tracks for?

That particular flight was cancelled and did not operate, so there is no track possible for it.

However, we did partially track that flight under NAX41U-1551818713-5-2-174 instead. It looks like there were some oddities with that flight’s data that cause us to only start tracking it part way across the ocean. We’ve tweaked some settings that should improve tracking of future instances of that flight.

Thanks. I got it working with some other flights. I just got that same error with a few flights. What are the odds… :slight_smile:

I am having the same issue, unfortunately.
Tried a few random flights and received the NO_DATA error:
CPA216-1556515574-airline-0065
BAW330-1556515573-airline-0277
AAL135-1556515570-airline-0487

However, the flight ID which @bovineone mentioned above did work.
Am I doing something wrong? Thanks!

Each faFlightID listed is at least a day out from departure at time of writing. In this case GetFlightTrack should be expected to return NO_DATA since no positions have been recorded yet.

When results are returned from endpoints like FlightInfoStatus they are ordered by filed_departure_time newest to oldest. The newest flights may be up to 48 hours in the future and will have an actual_departure_time of zero.