FlightAware Discussions

New Raspberry Pi available - Pi 4

Was that a manual update or automatic after a reboot?

I did sudo rpi-eeprom-update manually last week sometime, but I only rebooted it last night to trigger the update. The current firmware is:

BOOTLOADER: up-to-date
CURRENT: Tue 10 Sep 10:41:50 UTC 2019 (1568112110)
 LATEST: Tue 10 Sep 10:41:50 UTC 2019 (1568112110)
VL805: up-to-date
CURRENT: 000137ab
 LATEST: 000137ab

I think it was still running the original firmware from release previously - I had to manually install rpi-eeprom.

Same bootloader version, mine is at body temperature though running @1850MHz with -e:8.6

I’m suspecting that my power supply is not up to the task running a RPi4 and Airspy Mini.
Symptoms are random corruption on the SD-card, dropped packets when running airspy_adsb with -e > 8.6 and the core is running at 0.9 Volts (I think it should be at 1.2V, a bit hard to find RPi4 specific info on this, all other models have 1.2V).
The sdram measurements are at 1.1V, should also be 1.2V according to the documents I’ve found.

When I measure voltage on the +5V GPIO-pin (pin 2) I get 5.1 Volts, the power supply is the official for RPi4.

I tried to bump the CPU voltage up to 1.2V by using over_voltage=6 in /boot/config.txt. According to documents this should give 1.35V on the CPU (0.025V per step, 1.2+(6*0.025)), I get 1.038V.

What number are you getting on yours?
This oneliner outputs the relevant information:

for id in core sdram_c sdram_i sdram_p ; do echo -e "$id: $(/opt/vc/bin/vcgencmd measure_volts $id)" ; done

Thanks in advance :slight_smile:

Edit: Fixed the oneliner.

I’d remove that over voltage, but that’s just me.
Did you already have force_turbo in the config when you observed the lower voltage, because otherwise the system is free to clock down, that goes with reduced voltage.

You should get something for vcgencmd get_throttled if it’s really throttling and not just clocking down.
Try with no overvoltage and just force_turbo=1, then check for throttling.

1 Like

I have my RPI4 running @1850MHz and Airspy@ -e:8.6 with the following additions in config.txt:
force_turbo=1
over_voltage=4
arm_freq=1850

Running your oneliner will get me:
core: volt=0.9720V
sdram_c: volt=1.1000V
sdram_i: volt=1.1000V
sdram_p: volt=1.1000V

1 Like

As Wiedehopf said, try force_turbo=1, I got rid of my lost samples that way.
The reason I overclocked a bit was that while running with -e @8.5 on some good days I get more than 2200 ads-b messages/s and the ads-b cpu utilization would exceed 90%.
If I can run an overclocked RPi4 with the Airspy mini on a stock RPi power supply, you should at least be able to do that with a non overclocked RPi4.

1 Like

I’ll give it a go with force_turbo, just changed the governor to performance to make it run at 1500 continuously.

There is no throttling taking place, at least according to vcgencmd.

I also got a new PSU, but will try with the original first.

Exactly my thought. I have a pretty decent cooler and an external fan transporting away the heat. Not using the internal bias-t of the Airspy should give more than enough juice to keep it running unoverclocked.

Changed and used force_turbo=1. Worked for approx 8 hours before the SD-card failed (won’t boot or fsck without errors, so the card itself seem to have broken down).

Now recovering the readable files with the hope of keeping the stats and configs when transfering to a new SD-card.

That’s a shame, are you sure there’s nothing wrong with your RPi4?
I always have a backup RPi4 ready with a cloned sd-card just in case…
To avoid a sudden power loss during an sd-card write cycle, I’ve put both my Pi and Airspy on a UPS.

1 Like

No, I’m not sure that the RPi4 is ok. Bought it just a week or two after release so it may be from an early batch with problems. I’ll get some new SD-cards and clone them from the original so that I can be up and running again faster than this time…
It’s a bit annoying since I never had any problems with SD-cards in Pi’s after version 3…

The SD cards don’t like frequent writes. Some are more resilient than others, but more expensive.

Check this out:

1 Like

I think sd-card quality has massively improved and write reduction shouldn’t be necessary anymore.

Hmm, they omit the probably easiest and most effective way to reduce writes (especially if you are using the graphs).
https://github.com/wiedehopf/graphs1090#reducing-writes-to-the-sd-card

1 Like

Depends who makes them. A lot of them are bootleg clones.
Also, I noticed the transition from SLC (single level cell) to MLC (multi level first gen - two levels per cell) to TLC and even QLC (three and four levels per cell). That is improving only the cost and capacity, not endurance.

Ok ive lost my output for airspy to flightaware 3 reds
redone new sdcard with buster lite and then added as pi3 install piaware nothing working
any one got steps for buster and fa install / airspy
sorry to ask but looked through loads not finding correct place

thanks

Futher to post

ive just found i have got 2 new sites that i no nothing of not in my area not my ID
pic att


how did this happen
i cannot see my stats page just 3 reds and 2 other accounts
i cannot access piaware-config

pi@raspberrypi:~ piaware-config -bash: piaware-config: command not found pi@raspberrypi:~ rtl_test
-bash: rtl_test: command not found

I followed these instructions from @wiedehopf to install PiAware and Airspy on my RPi 4;

wiedehopf

Oct 8

Installing Raspbian Buster Lite on the Pi4 isn’t an issue, download the image, put it on the sd-card, enable ssh access, and plug it in.
Oh the WiFi setup is a bit different if it’s required, but not a problem either.

Following that you just install the piaware stuff: https://flightaware.com/adsb/piaware/install

Then you run airspy-conf and you are done with the setup: https://github.com/wiedehopf/airspy-conf#airspy-conf

From your description, you may have missed the airspy-config portion

As for your two new sites, unless you follow the instructions on retaining your feeder-id upon a new installation of PiAware, it will automatically give you a new feeder-id each time you install PiAware. I suspect you have tried installing PiAware a couple of times.

I have yes but these 2 extra sites are not new but existing sites added to mine altering my stats i cannot understand how as i didnt add them
i had problems after a new sdcard install from scratch as well
but just about to try again