My install of version 1.11 doesn't restart automatically


#1

Posted this in another thread but I think the question sort of got lost, so am re-posting as a new topic. I am running piaware v1.11 and the FA server is receiving my uploads fine, although as others have mentioned it thinks I have installed v 1.10.

Here is my problem: Whenever I reboot the pi, piaware doesn’t start automatically as it did with the first version I installed (think it was v 1.8). Although this is not a major issue since I can manually restart it but it’s not behaving like it should. I have reinstalled twice, followed instructions to the letter, but still apparently no auto restart.

Anyone else experienced this or have a solution?


#2

Does this command work?


sudo /etc/init.d/piaware start

If so then you probably need to do the following:


sudo update-rc.d piaware defaults


#3

Thanks for the suggestion. However, still cannot get things going automatically. The command

tail -f /tmp/piaware.out

produced this:

“if {!$tcl_interactive} {
main $argv
}”
(file “/usr/lib/piaware/main.tcl” line 97)
invoked from within
"source /usr/lib/piaware/main.tcl"
(“uplevel” body line 1)
invoked from within
"uplevel #0 source $path"
from tcllauncher running “piaware -p /var/run/piaware.pid”

Once I started piaware then the “tail” command showed that the connection was being made and data sent.

I tried your suggestion of "sudo update-rc.d piaware defaults"
but after a reboot was back to where things were, i.e. no auto restart.

As I said earlier, there are worse things to deal with, but it is curious as it worked in my original install of version 1.08. Think I’ll hold off trying to resolve this until the next release…