FlightAware Discussions

Mlat-client clock unstable (only sometimes)

I set up two PiAware feeders and both frequently exhibit the message “MLAT disabled/not synchronized/Latitude Longitude not set”.

Looking in the feeder log I noticed the following;

[2019-08-30 16:17 EDT] mlat-client(2643): Server status: clock unstable
[2019-08-30 16:32 EDT] mlat-client(2643): Server status: clock unstable
[2019-08-30 16:47 EDT] mlat-client(2643): Server status: synchronized with 106 nearby receivers
[2019-08-30 17:02 EDT] mlat-client(2643): Server status: synchronized with 90 nearby receivers
[2019-08-30 17:17 EDT] mlat-client(2643): Server status: synchronized with 97 nearby receivers
[2019-08-30 17:47 EDT] mlat-client(2643): Server status: synchronized with 108 nearby receivers
[2019-08-30 18:02 EDT] mlat-client(2643): Server status: synchronized with 92 nearby receivers
[2019-08-30 18:17 EDT] mlat-client(2643): Server status: synchronized with 102 nearby receivers
[2019-08-30 18:32 EDT] mlat-client(2643): Server status: synchronized with 109 nearby receivers
[2019-08-30 18:47 EDT] mlat-client(2643): Server status: synchronized with 104 nearby receivers
[2019-08-30 19:02 EDT] mlat-client(2643): Server status: clock unstable

Why would this be happening? Does anybody have any clues?

Thank you

The only time I had this problem was with an FA Pro+ stick that went bad. In my case, the stick’s sensitivity had also gone down.

It could anything from a bad USB cable or connection, bad power supply to a bad or over heating dongle. Not sure if a hot cpu does this.

In both cases, the dongle is directly connected to the raspberry pi, no USB cable.

Each raspberry pi is powered by a 5 VDC 2.5 A power supply.

Both dongles are new FlightAware Pro Stick Plus ADS-B USB Receiver with Built-in Filter.

I have ordered a 3 A powered supply, but it won’t get here before next week.

In most cases, the PSU’s current isn’t a problem, it’s the voltage. As they age, the voltage output goes ‘soft’ and drops below 5.0V. With a voltmeter, you can test your PSU under load.

How accurately did you set the location?

3 or better 4 decimal digits are required.

Also check that you set the altitude according to the units and reference.
I believe the default is to set it in feet above the ground, but you can also choose other options.

Apart from that the most likely problem is low supply voltage.

sudo dmesg --ctime | grep voltage

This only shows severe undervoltage.
The dongles can have unstable MLAT before that warning triggers.

What model RPi are you using?

1 Like

Thank you wiedehopf, your tip of setting the GPS coordinates to higher accuracy was the “magic bullet”. I used the map and set the coordinates very, very precisely. Mlat has remainded enabled the entire day.

Once again, thank you.