FlightAware Discussions

Lighttp

Is it possible to have dump1090-fa without having Lighttpd server locally?
is that I already have a program that runs lighttp, and when I install dump1090-fa I get the program page
thanks

That’s insufficient information about the problem, be more specific in describing your setup.

Dump1090-fa runs just fine without a webinterface.
But if you want a webinterface, you’ll need a webserver.

i don’t want the web interface
I already have a program using webinterface and when I install flightaware like this on the site, the program I have stops working.
I just want dump1090-fa to send the data to the flightaware site. No web interface.
how do i install armbian it in command line
tkx

The dump1090-fa lighttpd changes are installed as config modules and do try to keep out of the way of anything else that uses lighttpd. If it’s causing problems, try this to disable them:

$ sudo lighty-disable-mod dump1090-fa
$ sudo lighty-disable-mod dump1090-fa-statcache

tkx
but they are :slight_smile:
it would be nice if you could turn it off before installation ie install everything except the web interface

Eventually I’d like to move the web interface to a separate package (like skyaware978) but that’s not there yet.

How about a custom installation, ask if we want the web or not :slight_smile:

No plans for that at the moment.

:frowning_face:
but tkx anyway
:slight_smile:

If you want to work out exactly what’s interfering between whatever this other piece of software, and dump1090-fa’s lighttpd config fragments, then I can certainly take a look at fixing that. It’s meant to avoid interfering with anything else using lighttpd. You haven’t provided enough details at the moment unfortunately.

i’m running on an orange pi zero with SPOTNIK software, and amateur radio communication soft
(https://f5nlg.wordpress.com/2017/05/16/hotspot-compatible-svxreflector-echolink-free-radio-network/)
and it has a web interface as you can see there in the images.

when i install flightaware like this on page
(https://flightaware.com/adsb/piaware/install)
the error SPOTNIK web interface
lighttp

and… what is the error that you see?

I’ll take some print screens

I think you forgot to mention that lighttpd needs to be restarted.
Also disable mod is just terribly unreliable, i’d just use rm for the symlinks:

sudo rm /etc/lighttpd/conf-enabled/88-dump1090-fa-statcache.conf 
sudo rm /etc/lighttpd/conf-enabled/89-dump1090-fa.conf
sudo systemctl restart lighttpd

I don’t really understand what the issue is with first installing dump1090-fa and afterwards disabling the lighttpd integration?

Also this log is most likely interesting for checking on the problem, the page that you have on the screen after the command is sufficient:

sudo journalctl --no-pager -u lighttpd

ok before FA instalation
this is the SPOTNIK web interface

after FA install
fa web ok
FA_web-ok

but SPOTNIK is off like this

So as far as I can tell, your original post which said “I already have a program that runs lighttp” is actually wrong - this spotnik software seems to run its own webserver, not lighttpd, and the problem will be that the two webservers are competing for port 80.

Just disable lighttpd entirely then:

$ sudo systemctl stop lighttpd
$ sudo systemctl mask lighttpd
1 Like

yap you are right sorry

let me try and see if it works

You could also just reconfigure lighttpd not to use port 80:

sudo nano /etc/lighttpd/lighttpd.conf

Find the server.port line and change the 80 to for example 99.

Ctrl-X to exit, y(yes) and enter to save.

sudo systemctl unmask lighttpd
sudo systemctl restart lighttpd

That would mean you also have the dump1090-fa webinterface :wink:

:partying_face:

that would be great

im install all again

donne the install

and disable the lighttp

no fa web
but spotnik its ok again

tried to reconfigure the opt 80 to 99 but still do the problem, maybe the to webservers cant be on same time