FlightAware Discussions

Keeping feeder ID on new install

I’ve read the following but none of the instructions have worked for me:


I had to replace the SD card on my Raspberry Pi (3B+), so I had to freshly install piaware. When I run the piaware-config feeder-id 12345678-1234-1234-1234-123456789abc

command, I get

Set feeder-id to 12345678-1234-1234-1234-123456789abc in /etc/piaware.conf:1 could not write new config files: couldn't open "/etc/piaware.conf": permission denied

I also can’t edit /boot/piaware-config.txt.

How do I update my new installation to continue using my existing feeder-id?

Put sudo in front of the command.

I’m stupid. Thank you.

The instructions on the site need to be updated to include the sudo part as it catches people out. It’s there in step 4 for the final restart but not for the piaware-config part nor the suggestion of editing the file (requires sudo nano or similar).

This does include sudo :

  1. For Begginers - How to Get Back Existing Station Number in A Fresh Install

.
Some additional "How To"s

  1. For Beginners - How To Set Receiver Location

  2. For Beginners - How to Enable Sending Remote Commands to Pi from Stats Page

  3. For Beginners - How To Remove Unused Site from Your Account

  4. How To Format Messages in This Discussion Forum

  5. What is the Maximum Range I can Get?

  6. Three Easy DIY Antennas for Beginners

  7. Do I Need A Filter?

2 Likes

I never enter the sudo for piaware-config changes, and it works fine. It may depend on how people access the Pi, I guess. I use PuTTY, and login with the FA default user and pwrd.

Since there or both types of accesses, requiring / not requiring sudo, it is advisable to include sudo in a guide/howto, to cover both cases.

1 Like

If your not using sudo it will because of the file permissions, to edit via putty or WINSCP you must have chmod 77* the file to amend permissions.

Same here. Without sudo the file can’t be altered.

[ Error writing /boot/piaware-config.txt: Permission denied ]