FlightAware Discussions

Intermittent Data Fetch issue

Nothing has been altered but now I get this every 10 secs or so:

Problem fetching data from dump1090.
AJAX call failed (timeout: timeout). Maybe dump1090 is no longer running?
The displayed map data will be out of date.

Occasionally I have anomalies with MLAT and with UDP(19%)?

The pi temp is 55C - is my SD card failing?

Kind Regards

Hugh

Much more likely reason is an insufficient power supply (MLAT problems) and bad WiFi (udp packet loss and AJAX timeout).

Note that the insufficient power supply could also influence the WiFi a bit.
Unless you have an official RPi power supply, that’s always a good place to start.

Very many thanks - I appreciate your reply. I agree: I’m using an official Pi PSU - but it could well be failing: it’s pretty hot in the attic!

“23% of UDP multilateration traffic sent by piaware is not reaching the FlightAware servers. This may indicate a network problem.” - an anomaly …

Kind Regards - Hugh

Oh i misunderstood that.
Unless MLAT is actually getting red, it’s working fine even with the packet loss.
(MLAT getting i’d check the power supply but this is network only)

You can try changing the channel on the router or repositioning the RPi a bit.
Depending on orientation the WiFi can work a lot better or worse.

Good thought! Thank you.

Hugh

It’s died completely. No response via ssh. I’ll investigate in the morning.

Hugh

Back up and running. The pi fans were making a noise … stalled? Drawing too much current?

Seems to be ok now.

Hugh