FlightAware Discussions

How to stop PiAware from rebooting pi?

Shortly after “upgrading” (to 3.7.1) I noticed frequent (twice nightly) rebooting. After a goose-chase, i found that PiAware was the culprit –

[2019-05-30 04:11 EDT] no new messages received in 3889 seconds, it might just be that there haven’t been any aircraft nearby but I’m going to try to restart everything, just in case…

PiAware is not the only thing I use my raspberry pi for! When PiAware reboots my raspberry pi, all my other services (nextcloud, nginx, etc.) are interrupted. I am pissed off about this.

How to stop it?

237                 logger "no new messages received in $secondsSinceLastMessage seconds, it might just be that there haven't been any     aircraft nearby but I'm going to try to restart everything, just in case..."                                                     
238                 faup_disconnect
239                 if {$adsbDataService ne ""} {
240                     ::fa_services::attempt_service_restart $adsbDataService restart
241                 }

That is the code that spits out that message.
Only dump1090-fa is restarted, not the RPi.

Thanks for the info. The pi is definitely rebooted, something else must be failing when the dump1090-fa service is restarted… I’ll dig deeper.

Check the journal:

sudo journalctl -b-1 -e

That should show the last shutdown.

Yeah, the only way that piaware will cause a reboot is if you have manual commands enabled and request a reboot via the stats page; it certainly doesn’t do any sort of automated reboot. (True for both package & sdcard installs)

As an aside, the piaware process runs as a relatively unprivileged user, and the only way it gets access to e.g. reboot the system or upgrade packages is via some specific sudo rules - see /etc/sudoers.d/piaware - and any use of those commands will be logged by sudo.