How to setup the SDR for maximum and close range? Impossible?

BTW many thanks for your constant input in this forum. I guess without your support and time this would be a lot more frustrating!
Attached three pictures from my collectd stats. My memory keeps on rising - is this going to be a problem?

The gradual increase in disk usage may be due to log files. Delete /var/log/piaware.log, var/log/fr24feed.log, /var/log/dump1090-fa (or mutab).log, /var/log/pfclient/pfclient*, and also files with .1, .2 etc at the end. After deleting these log files, reboot so that fresh blank copies of these files are created by system.

Did you choose yes to “advance options” when installing web portal/graphs? This option also saves lot of data on disk and fills it up.

Thanks, I´ll monitor that. No I did not choose yes afaik. The sd card is 32gb so enough space but I´m afraid that the ram will be insufficient.

Well, about half of the1Gb RAM is unused right now, and most of it is some form of Cache, basically the os took the opportunity of free RAM to put things there to improve performance. So you should be ok.

I was going to jump on that solution, but with modesdeco2 having such a high usage…

May be something wrong with my install. It is unbelieveable that modeSDeco2 has such a high CPU usage, else it would have been reported in radarspotter’s forum.

It is better few others also try. It takes less than half an hour including serialization of two dongles.

If you find in your install also it has a very high cpu usage, you can delete it by deleting its folder msd2 and deletimg startup entry in /etc/rc.local.

tried it again with a fresh raspian stretch and itś still not working. Dump-fa is running but modesdeco2 is not working or reachable at :8088

  1. Give command top, and see if it is running.

  2. The wget command in my post is for ModeSDeco2 for Jessie. I used it on Piaware SD Card image which is Jessie. Possibly it failed because you used it on Stretch.

  3. I checked the download site:

    From this site I have downloaded ModeSDeco2 .tgz file to Windows Desktop, then uploaded to Dropbox, and finally used wget command to download from Dropbox to RPi.

    They have not yet released version fo Stretch.

The site is decieving. As the names ModeSDeco2 and ModeSMixer2 resemble so much, couple of years ago when I visited this site to download Decoder for Windows, I downloaded Mixer for Windows, and was struggling for hours to make it work as Decoder before finally discovering I have downloaded Mixer. :frowning:

OK, so am I right that Modesdeco will not work with rasp stretch now?
I will try it with jessie, lets see.
Thanks anyway for your support.
Btw is there a simple way to remove dump1090 mutability and Install dump-fa or is it better to Install -fa in a new Image?
I checked -fa yesterday and I like it more. The altitude filter and showing Infos by mouse-over is much more convenient for our flightcontroller.
An additional rainradar layer for Europe would be nice. Are the mlat data the same as I have in dump mutability? These are quite good in my area.

There are two ways to change mutability to fa:

(1) Keep the dump1090-mutability, but replace its two-clock map by SkyView map of dump1090-fa

(2) Remove completely dump1090-mutability, and in its place install dump1090-fa

Both these methods are given here as options (a) and (b):

TWEAKS >> Tweak-2

In option (b), which is for completely removing dump1090-mutability, there are two commands given, one is --remove, second is --purge. Actually only one of these is required, and --purge is better. If you give both, the first one will work, next wont. Better do not use --remove command, and give only --purge command.

I wonder if we can run both dump1090-mutability and dump1090-fa, and set one of them to grab a different ID radio.

Have tried someties ago. Failed. They clash and cant coexist. May be some one else knows how to make them compatible.

1 Like

I´m not able to get modesdeco run, don´t know why.
Neverthelss how would a script look like, to reduce the gain for example from 8 to 18 UTC to gain 7.7 and the rest of the day at gain 28.0?
I think this could be the easiest way without installing new hardware.
Thanks for help.

Maybe line-break problem in the code of file Try single line coding given below. As all parameters are in a single line, it is very long line, but without line-break issue

/home/pi/msd2/modesdeco2  --device-serial 1001  --gain 49.6  --freq-correction 62  --location XX.XXXX:YY.YYYY  --web 8088  --metric    

If in the code of file you have NOT replaced XX.XXX:YY.YYYY by your actual latitude:longitude, it may also be cause of failure.

Hi, I replaced the coords and I set the serial no at 0 or 1 because my sticks has 0000 and 0001 but it didnt Work with 1001 as well.
Maybe something with the sudo nano /etc/rc.local procedure is buggy. How should rc.local look like finally?

Do not use device-serial 1001 if your dongles have serial 1 and 0. Use what your dongle has, i.e. use1.

Try to run manually. If it runs, then something wrong with rc.local

cd msd2
./ &  

Ok, need to install it again but maybe its because I try it with raspian stretch because I want to have the desktop.
Another thing confuses me - collectd stats is not collecting data with dump1090-fa. I modified the file according Can collectd use dump1090-fa to collect stats? If so, how but collectd shows only 3 panels with data and the rest says no data.
Is there another tutorial how to run collectd with dump-fa?

I think that the numbers should be between 0 and 999. Flashing different serial numbers:

I have 2 Pro Stick and 1 ProStick Plus. All three had factory set serial number 00001000
I have 2 Generic +1 NooElec DVB-T (Black) dongles. All three had factory set serial number 00000000

I have changed serial number of one ProStick to 00001001 and other to 00000000. These are successfully working for dual system. The 00000000 is always grabbed by dump1090-fa and 00001001 is always grabbed by MoseSDeco2.

Using RTL1090 on Windows to view/set serial number

Step-1: Give command C:\rtl1090>rtl1090.exe /eeprom
(My rtl1090.exe is located in folder C:\rtl1090 that is why I have used this path. You have to use the path in your computer)

Step-2: Click START button on RTL1090 window.

Step-3: Set serial number and press Continue button.