FlightAware Discussions

How to fix local web interface/view live data link?

New FA feeder/user here…

So far everything is working except the web interface/live data link. I forgot I had another RPi package installed which had a web interface & 8080 port, so I removed it. But after installing PiAware and dump1090 which from the FA end is working, the only thing not working is my local web interface. My RPi 192.168.1.xx:8080 just shows ‘site can’t be reached’ message.

How do I fix it-- do I go through the install steps again? Will that reassign a new site and receiver number? Apology for the newb mistakes/questions. Or do I just keep this as is and view all the stats from FA/SkyAware end?

Thanks!
Robert

did you try clearing your cache from your browser ? maybe it is still looking for the old program on port 8080

you should check if the required lighttpd is running:

sudo systemctl status lighttpd

It should show “active (running)

Yea tried that, still no go. I think the previous package might have fubar’d some existing packages/links.

Yes! That’s the culprit. Showing ‘failed’…

Process: 610 ExecStartPre=/usr/sbin/lighttpd -tt -f /etc/lighttpd/lighttpd.conf (code=exited, status=255/EXCEPTION)

lighttpd.service: Start request repeated too quickly.
lighttpd.service: Failed with result ‘exit-code’.
Failed to start Lighttpd Daemon.

So what commands do I use to fix this? Or packages to install/re-install?

I assum the server cannot start because the port is in use.

You need either find the blocking program or reconfigure lighttpd to a different port.
Configuration file is in /etc/lighttpd

Debug commands · wiedehopf/adsb-wiki Wiki · GitHub

1 Like