Graphs 1090 question


I got a Graphs1090 question that’s probably easy to solve but it has me stumped.

I’ve upgraded Graphs1090 from source but since then the page isn’t showing anymore graphs.
All the items are there but no graphs.
Removing and reinstalling doesn’t fix the issue, I even purged the package to start fresh but it still ends up like in the screenshot.

Does anybody have some advice on how to fix this ? Maybe @wiedehopf ?
The problem is probably located between the chair and the keyboard but I can’t think of any solution at this point in time.
Many thanks in advance.

GitHub - wiedehopf/graphs1090: Graphs for readsb / dump1090-fa / dump1090 (based on dump1090-tools by mutability)

Thank you sir, I must have overlooked that part on reporting issues.

Here’s the link

In the logs I see that the file or map containing the graphs do not exist.

Thank you in advance

sudo journalctl -u graphs1090 | tail -n30

Here’s the output:

So that looks normal.
This does not … didn’t see it yesterday:

25923 (process ID) old priority 0, new priority 19
ERROR: expected : after font size in 'TITLE:10,000000000:.'

Don’t use NL locale … is probably the answer.

I’ve changed something to work around people setting locales … i’ve seen people use locales and so far there were no issues.
I suppose could be because you changed the font size in your settings and had a certain locale.

Anyhow try updating …
Or use English on your pi, localisations besides setting local times only leads to issues :stuck_out_tongue_winking_eye:
One issue is for example logs you send me have bits of language in them i don’t understand.

Or maybe you have a comma instead of a dot in the settings file?

# font size, default 10.0 (relative to graph size)

Yeah no i think it’s just the locale and your systems awk version complying to POSIX being extremely stupid.
Anyhow … let’s hope my change fixes it.

1 Like

It’s fixed indeed, changed the locale to en_US.UTF-8 and updated.

Graphs are now visible again.
I didn’t change anything in regard to the fontsize or locale, it was there from day one.
Glad to see the graphs for this flightfeeder again.

Thank you very much @wiedehopf :blush: :partying_face:

You should be able to continue using your locale due to the changed script.

I might want to limit the changed locale to awk i suppose … yeah that’s what i’ll do just to make sure the date formatting in the graphs remains unaffected.

Again you should be able to go back to whatever locale you prefer now with the version i just pushed.

Thanks @wiedehopf.

English is fine by me, don’t know why this one had the dutch language, all other Pi’s are running on english so it’s fine to leave it that way.
As you mentioned, it eases troubleshooting due to all language being in english instead of dutch :blush:
thank you for your assistance in getting this fixed :+1:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.