FlightAware Discussions

Fixing duplicate sites?

Hello, all. After getting my FA Pro Stick working, I now have a problem with duplicate sites. From my ‘claim stations’ page, I see:

Site 118293 - Radnor-Winston Neighborhood - 85745c9f-cda6-4160-84aa-24b1a432d619: PiAware (SD Card) 3.8 added Thursday, January 2, 2020 (72.71.150.192 / 192.168.1.7)

Site 117993 - Radnor-Winston Neighborhood - 658c225c-7cb7-474e-ae79-5441209e5ad5: PiAware (SD Card) 3.7 added Thursday, January 2, 2020 (72.71.148.143 / 192.168.1.10)

These are both the same site. 117 was established when I first powered up the Pi Zero, but before I had the Pro Stick working. 118 is after everything is working. 117 has no flights recorded, and says the radio is not working. 118 has over 500 flights since last night, and seems to be working correctly.

I think this was caused by both rebooting the Pi, and therefore giving it a new internal IP address (192.168.1.7 in place of .10) and rebooting my router, giving it a new IP address, too (72.71.150.192 in place of 72.71.148.143). It could also have been caused by upgrading from Piaware software 3.7 to 3.8

My questions are:

  1. How do I get rid of the 117 site?
  2. Will this take place every time I reboot either my Pi or router and either one gets a new IP address? Or upgrade software? Is there any way to prevent this?

Thanks for your help and advice.

-Kevin

The dead site will go away on its own, you don’t need to do anything.

Sites are identified by the feeder ID shown on the site stats page. This is stored on the sdcard. If you re-image the sdcard, a new feeder ID (and therefore site) will be generated. You can override this by configuring the appropriate feeder ID using piaware-config