Feeder live but Data feed dead after upgrade to USB ProStick


#1

I finally got around to installing my USB Pro Stick on my RPi2B this afternoon.

I halted the Pi using the option on my ADS-B page and then disconnected the old NooElec SDR and attached the Pro Stick. Powered back on, got all the steady power light etc and returned to my desktop.

Right now I’m getting that the Feeder is live and checked in a few minutes ago but the data feed is not updating. I’ve SSH’d in to the box and and did an apt-get update etc and that all worked.

I’ve also tried a few reboots. Any suggestions on what I can try next to get the data feed going?

Thanks!

EDIT: Few other snippets of information, it would appear that dump1090 is not starting:

pi@piaware ~ $ sudo /etc/init.d/fadump1090.sh restart
…] Stopping dump1090 server: dump1090/sbin/start-stop-daemon: warning: failed to kill 3287: No such process
. ok
…] Starting dump1090 server: dump1090…] 0

pi@piaware ~ $ sudo piaware-status
dump1090 is not running.
faup1090 is not running.
piaware is running.
no program appears to be listening for connections on port 30005.
faup1090 is NOT connected to port 30005.
piaware is connected to FlightAware.
got 'couldn’t open socket: connection refused’
maybe dump1090 is NOT producing data on port 30005.


#2

So funny story, the FlightAware Pro USB sticks plastic cover extends over the USB plug a lot more than most USB devices. Plugging it in to a Pi that has a plastic case means that if its not pushed in hard and perfectly aligned the data lines don’t reliably connect.

I had done an lsusb and the stick didn’t show in the list which turned me on to this issue. After fiddling with it I finally got it to start.

However, my range dropped to about 20 miles which was quite the difference from the NooElec. I tried changing the gain from -10 all the way to 10 and found the best results at 30 but still well down from prior performance.

For now I’m back to the NooElec.

Setup is RPi2-NooElec-FlightAware Filter-FlightAware 1090 antenna.