FlightAware Discussions

Feeder Checks in but No Data

Folks,

I reside in UK but have a PiAware system operating at a friend’s address in US.

Checking the stats page it shows the feeder check in minutes ago but no data for 3 days. It also shows on stats page the local IP address which I knew it to have.

Appreciate networks can go down but baffled as to how feeder can check in but no aircraft or positions reported.

Geffers

Suggest you ask your host to swap the USB PSU. And if that fails (to fix it), try another USB cable.
It’s not an uncommon problem.

Have you tried remotely rebooting the Pi?

S.

1 Like

Not tried rebooting yet, happened once before and she said the network was down and rebooted the router, but again the stats page was indicating the feeder had checked in so that would indicate the network was actually OK at that time.

Connection by me is via ssh to a different computer on her network but of course am then able to ssh from that machine to Pi but initially curious how feed can be contacted but no data.

I’ve disconnected the antenna before and still had some data.

Geffers

PSU is an option but it is a Pi Zero and current shows around 400mA powering the Zero and the tuner.

If I find the problem I’ll get back to this thread.

Geffers

It’s not about the network.

The dump1090-fa can hang and refuse to be restarted via the systemd service.

It’s easiest to just reboot to fix such problems. (called wedge. often caused by power problems)

Sometimes it is enough to kill and restart dump1090-fa like this:

sudo pkill -9 dump1090-fa
sudo systemctl restart dump1090-fa

Sometimes the USB device needs to be powered down and up to resolve the problem so only a reboot will help.

Why not? Do you have some other plan for getting it restarted?

Personally, I’d get on a plane and go and have a look at it. I have a system on Cocos Island that has been down since before last xmas. It is easier to get to the US than Cocos (Keeling) Island.

S.

2 Likes

Phone chargers simply don’t appreciate running constant load. They are designed for an hour or two charging once a day.

I tossed three last year as they went soft (~4.5V).

1 Like

I’m on a plane tomorrow (3rd April) but not because the Pi wasn’t working :sunglasses:

It is working again, she said there were network issues so am not sure what caused the problem, the log file didn’t really give me any inspiration. She did not reboot the Pi but all is now working again.

As suggested in this thread a reboot (even of router) can solve a lot of problems.

Today damp, dismal London, tomorrow Southern California :cowboy_hat_face:

Geffers

Google says

Tuesday, 2 April 2019
Date in Melbourne VIC

Are you sure you are flying tomorrow?

S.

2 Likes

That’s me getting all excited - 3rd April. Got the boarding pass so must be OK.:nerd_face:

Geffers

Glad we sorted that out.

Have a great trip!:flight_departure: :flight_arrival:

S

1 Like

Enjoyable journey, British Airways 747 Heathrow to Chicago then American Airways 737 -800 to San Diego.

Don’t realise how big a 747 is until you fly a 737 :cowboy_hat_face:

Geoff