FA Diadnostics help


#1

Hi All,
Since several days my FlightAware stick is receiving nothig.
I have a plenty logs entry like this:
2018-03-25 22:44 CEST] 0 msgs recv’d from dump1090-fa (0 in last 5m); 0 msgs sent to FlightAware
Is it possilbe that the stic is broken?
Whole system was working quite weel, suddenly it stoped.
is it possilble to diagnose it more deep on log level?
Thanks in Advise
Wojtek.


#2

Did you try a reboot?


#3

Yes, many times. Since the begining I have to wait some severak minutes to have the stick working (receiving any data messages greater than zero). Now it is not collecting ANY messages. I am courious how to deeper look into FA dongle diagnostic data.


#4

I have started dump1090-fa maually and received following output
pi@piaware:~$ sudo dump1090-fa
Sun Mar 25 21:28:22 2018 UTC dump1090-fa 3.5.3 starting up.
rtlsdr: using device #0: Generic RTL2832U (Realtek, RTL2832U, SN 00001000)
No supported tuner found
Enabled direct sampling mode, input 1
rtlsdr: tuner gain set to 0.0 dB

seems it does not recognize stick :(?


#5

@poziomka07

  1. Pull out the stick from Pi, then re-plug firmly into Pi, and reboot Pi.

  2. If the Stick is connected through a USB cable, remove the cable, and plug the stick directly into Pi and reboot Pi.


#6

Yes…pull out the stick, that’s another must. What kind of stick is it (type, brand)?

I’m puzzled by this message: “Enabled direct sampling mode, input 1”. This is typically the case if the stick is being used to receive HF frequencies (3-30 MHz).

Also, this one “rtlsdr: tuner gain set to 0.0 dB”. Did you try changing the gain? If it’s truly set to 0.0 dB, it’s not likely to receive anything.


#7

I have original FA USB PRO Stick: https://flightaware.com/adsb/images/ProStick_Plus_open.jpg
I just unplugged stick and plug it in, after that i did manual reboot “shutdown -r “now”” but still has 0 msg frames from radio on piaware.log:
Mar 25 21:58:25 piaware piaware[491]: 0 msgs recv’d from dump1090-fa; 0 msgs sent to FlightAware
I am pretty sure the dongle has HW failure in it. I will claim warranty replacement.
Wojtek.


#8

Did you try changing the gain?

piaware-config rtlsdr-gain -10

Then:

sudo systemctl restart dump1090-fa


#9

Yes, I did both command:
piaware-config rtlsdr-gain -10
sudo systemctl restart dump1090-fa
Log:
Mar 25 22:13:25 piaware piaware[491]: 0 msgs recv’d from dump1090-fa (0 in last 5m); 0 msgs sent to FlightAware
Mar 25 22:17:58 piaware piaware[491]: lost connection to dump1090-fa via faup1090
Mar 25 22:17:58 piaware piaware[491]: faup1090 exited normally
Mar 25 22:17:58 piaware piaware[491]: reconnecting to dump1090-fa
Mar 25 22:17:59 piaware piaware[491]: ADS-B data program ‘dump1090-fa’ is listening on port 30005, so far so good
Mar 25 22:17:59 piaware piaware[491]: Starting faup1090: /usr/lib/piaware/helpers/faup1090 --net-bo-ipaddr localhost --net-bo-port 30005 --stdout --lat 50.029 --lon 18.440
Mar 25 22:17:59 piaware piaware[491]: Started faup1090 (pid 1543) to connect to dump1090-fa
Mar 25 22:18:25 piaware piaware[491]: 0 msgs recv’d from dump1090-fa (0 in last 5m); 0 msgs sent to FlightAware


#10

Try this test and post the output
.
1. Install test package

sudo apt-get update
sudo apt-get install rtl-sdr
.

2. Stop dump1090-fa

sudo systemctl stop dump1090-fa

.

3. Run the test command

sudo rtl_test -t

.

My HEALTHY Pro Stick gives this output

Found 1 device(s):
0: Realtek, RTL2832U, SN: 00001003

Using device 0: Generic RTL2832U
Found Rafael Micro R820T tuner
Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
[R82XX] PLL not locked!
Sampling at 2048000 S/s.
No E4000 tuner found, aborting.

.

4. Restart dump1090-fa

sudo systemctl restart dump1090-fa

.
.


#11

After steps you have posted, yhe output is:
pi@piaware:~ sudo systemctl stop dump1090-fa pi@piaware:~ sudo rtl_test -t
Found 1 device(s):
0: Realtek, RTL2832U, SN: 00001000

Using device 0: Generic RTL2832U
No supported tuner found
Enabled direct sampling mode, input 1
Supported gain values (1): 0.0
Sampling at 2048000 S/s.
No E4000 tuner found, aborting.
pi@piaware:~$

Wojtek


#12

Seems tuner chip has gone bad.
If your FlightAware Pro Stick Plus is still under waranty, return it.
Otherwise purchase another one.

Try following before you return the Pro Stick or order a new one:

Watch for a while the red LED light of Pi. It should be ON steadily. If it is blinking, then problem is with 5V DC supply, possibly Power Adapter has gone bad. Try another 5V DC adapter.

Even if it is not blinking, if you have another 5V DC adapter, try it. Often Sticks dont work properly if the DC supply is not OK.

One more thing. If Stick is connected to Pi through a USB Cable, remove cable and plug the Stick directly into the Pi.


#13

Thank You very much for help!
I will do as You have proposed, before I will check power supply. I do not use extra USB cable, The stick i plugged directly into USB port of PI board.

Kind regards,

Wojtek Szczepka