dump1090 won't respond to IPv6


I am running PiAware (Debian Package Add-on) 3.3.0 which is running dump1090 on lighttpd. The default server with placeholder page is running on port 80 just fine. I can connect to it with its ipv4 address and ipv6 address. When I try to connect to dump1090 (on port8080) with ipv4 everything is fine, but when try the ipv6 address it gives “refused connection”. I edit the config files and ran the main server on port 8080 and dump1090 on port 80…and I still can only connect to dump1090 on ipv4…default server, now on port 8080, I can still connect on both ipv4 and ipv6 addresses.

How do I enable dump1090 to listen on the ipv6 address?


Thanks in advance,


at least as I know, maybe I am wrong but I think only dump1090-mutability support ipv6

Sent from my SM-N910F using Tapatalk


What dump1090 are you using?


I don’t need to send updates to flightaware over ipv6…I would like the local web server to serve over ipv6. (thanks, though…googled that a lot.)

I am using the “stock” dump1090 that came with the piaware debian packages. In the upper right corner of the (local, not flightaware) server it says: FlightAware dump1090 v3.3.0



With dump1090-fa it is lighttpd that is serving on port 8080 so it’s lighttpd that you need to convince to listen on a IPv6 address.

Try editing /etc/lighttpd/conf-available/89-dump1090-fa.conf and change

  $SERVER"socket"] == ":8080" {


  $SERVER"socket"] == "::]:8080" {



THANKS! (Using my AOL font.) It works perfect as far as I can tell.