FlightAware Discussions

Dump1090-OpenLayers3-html

Today i finally managed to get dump1090-fa and skyaware up and running .
I then attempted to add Alan Kissack Dump1090-OpenLayers3-html following instructions .
Set my options at the bottom of config.js (you must also update your site lat/long (2 places) in this file), clear your browser cache and re-load your dump1090-fa page.

I have cleared the cache i dont know how many times ,rebooted the RPI4B but still default to the original skyview version 5.0.

I have exhausted all avenues for information on why i cannot get Alan Kissack Dump1090-OpenLayers3-html working.
Could someone help me with this problem please ???
Thank you in advance
Graeme

After reading your post I was curious because I had never heard of Dump1090-OpenLayers3-html. I downloaded the files, replaced my current /usr/share/skyaware/html with the files from Al Kissack and it worked right out of the box. I hadn’t opened Skyaware on this browser today and I always have my browser delete cookies and cache when I exit.

Check this thread. It has more instructions and someone there had a similar issue as you do. I hope that helps.

Hi Jepolch

Thank you very much for your help.

I had Dump1090-OpenLayers3-html in /usr/share/dump1090-fa/html.
I also put the Dump1090-OpenLayers3-html in /usr/share/skyaware/html

I then configured the config.js in both again.
Also the index.html was renamed gmap.html according to a post in this forum.
One thing i noticed was in the Dump1090-fa the config.js was from another dump1090 as it had 2 x latitude and 2 x longtitude to adjust with my own co-ordinates.
I must have been playing about with another config.js file and got them mixed up.
Any way the good news it worked late last night. Thought i give it a check this afternoon as i was tired last night.

2 questions i need to ask .

1.Can i confirm that the index.html had to be changed to gmap.html ???
2.Also does Alkissacks files reside in both /usr/share/skyaware/html and /usr/share/dump1090-fa/html ???
Once again Jepolch Thank you very much for your help
Regards
Graeme

Here is my bit of script to install Al Kissack’s interface. The instructions are out of date following the release of Skyaware. Joe Prochazka’s script is also out of date so I’d steer clear of it. I had to change some of the directories that things reside in after the upgrade to Skyaware. I’ve left the originals behind //
You can probably ignore lines 2,3 and 4 as you have a fresh install.
After the reboot I usually do a cache refresh.
I use the Piaware zip file https://piaware.flightcdn.com/piaware-sd-card-5.0.img.zip rather than building the application by hand.

//alkissak map install
//sudo mv /usr/share/dump1090-fa/html /usr/share/dump1090-fa/html-original
sudo mv /usr/share/skyaware/html /usr/share/skyaware/html-original
sudo apt-get update --fix-missing
sudo apt install git
sudo git clone https://github.com/alkissack/Dump1090-OpenLayers3-html.git
sudo mv Dump1090-OpenLayers3-html html
cd ~
//sudo cp -a ~/html/public_html/  /usr/share/dump1090-fa/html/
sudo cp -a ~/html/public_html/  /usr/share/skyaware/html/
//sudo nano /usr/share/dump1090-fa/html/config.js
sudo nano /usr/share/skyaware/html/config.js
change the lat and lon
sudo shutdown -r now
2 Likes

You’re welcome. I’m glad it’s working for you now.

I didn’t make any changes in /usr/share/dump1090-fa/html.

In /usr/share/skyaware I renamed the html directory to html-orig. Then I created a new empty html directory in /usr/share/skyaware. I then unzipped the master.zip file from Al Kissack’s github and copied everything from his public_html directory to my new html directory.

I don’t see a gmap.html in Kissack’s files, only index.html. I only modified my Lat/Long in /usr/share/skyaware/html/config.js.

Best of luck.

Hi triggers

Thank you very much for your post .
I have copied it to a txt file for future reference in case i need to re-install.
The missing link was to do with /usr/share/skyaware which i did not know about until Jepolch mentioned it.

Wish i had known about as it would have saved me countless hours trying to get it to work.

Thank you triggers for the info also

1 Like

@jepolch

Since my system upgraded automatically to Piaware 6.1 last week, the Al Kissak graphs stopped working. I’ve run my script above but I just get the spinny wheel when opening the web page. Checking ip of the pi:8080 just gives the lightppd holding page.

The Pi is still sending data to Flightaware and the @wiedehopf graphs are working OK. Are yours still OK and do you have any suggestions I can try?
I’ve also been testing the Airspy new releases so that may have had an impact.
Thanks

That doesn’t mess with any of that.

You’re overwriting the skyaware interface which is part of dump1090-fa.
When you update dump1090-fa … that correctly overwrites all of that again …
Thus you need to reinstall this stuff.

Ctrl-F5 might help if you already did the overwriting.
Otherwise check the browser dev console, usually accessed using F12.

Thanks for the information. I thought the Airspy new releases would have no effect, but the Pi has had a lot of updates in the last couple of weeks.

I’ll do a re-install of dump1090-fa as a start.

No you didn’t quite catch my drift, installing / updating dump1090-fa will OVERWRITE everything in /usr/share/skyaware
So you need to reinstall this mod.

It would me much better to keep this mod separate from this directory and have its own lighttpd config.
But i can’t be bothered setting that up, maybe someone else can explain how to do that.

I did get your drift but I’ve been deleting various files/directories to clean up the Openlayers stuff as it looks like I’ve got multiple copies of it in various places :scream:. If I re-install dump1090-fa I should have a clean version of it on the pi.
Thanks

That likely means you’re missing the lighttpd configuration for dump1090-fa.
Not sure what exactly is needed to restore that, purging and installing dump1090-fa might do it.

Otherwise just use lighty-enable-mod to enable the configuration file for it.
You can find the lighttpd configuration stuff in /etc/lighttpd/conf-enabled and conf-available … i’m sure you’ll figure it out.

OK, thanks. I’m tempted to start afresh and format the SD card. There’s nothing else running on the pi except the FlightAware stuff so no big deal.

I installed OL3 as a test - out of curiosity - but I’ve since gone back to using Skyaware.

OK, thanks. I’ve decided to run with what I’ve got for a few days and get a Pi 4 for the Airspy with brand new downloads to get rid of the chaos I’ve caused.

1 Like