Dump1090 Not feeding


#1

Ever since I updated my ADS-B Feeder to 3.5.0 (Piaware Skyview), I am loosing my feed about every 6 hours-ish. I get my email from flightaware that I am no longer feeding. Been going great for 2 years until the new software update.

Here is my screenshot when connected to the Skyview.

https://drive.google.com/open?id=0B2c6IITkXattZUM5cWNiSk11SkU

Any thoughts or should I do a whole new image?


#2

What does /var/log/piaware.log say?
What does “sudo systemctl status dump1090-fa” say?

edit: Looking at your logs, it looks like dump1090-fa is wedged.
That usually means a hardware or power problem.
The systemctl status output may help narrow it down.


#3

I would find it very odd that it would be a hardware or power problem immediately following the update to 3.5.0.

I don’t have systemctl installed, as I cannot find the systemctl.

I have basic understanding of linux, being able to get around, etc.


#4

If you are running a piaware 3 sdcard image or a Raspbian Jessie image then you are running systemd and systemctl will be present, please try running the systemctl command above.

If your system was borderline before then a small software change could have pushed it over the edge. Or it could be coincidence, hardware going bad at about the same time as an upgrade.

What did you upgrade from?


#5

I have the same probleme here since the upgrade to 3.5.0, so I don’t think it is a hardware issue.

I am running Raspbian 7/Wheezy, and since the update, the feeding stops after one or two days.

It seems that dump1090-fa has a problem, top says that it uses 100% CPU.

Skyview is still available, but no planes are there.

Everything was fine before for two years, power supply is an original 2A Raspberry Pi power supply, no issues with it before.

Systemctl is not available, so what to do?


#6

Easiest option re-image your SDCard with a new PiAware image.

Copy your piaware-config.txt off from the sdcard first. reimage, add a blank “ssh” file to the /boot folder. compare the old and new piaware-config.txt to see if anything outstanding is causing the issue,

you may also need to add your feeder-id into the piaware-config.txt like so:

feeder-id xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

reinsert card into raspi and reboot.

if your using wifi of course you also need to readd the wifi usernmae/password etc.

of course ignore my suggestion and spend days communication/diagnosing in the forums just to find you need to reimage your sdcard - lol


#7

Wow, you are so clever, but you can not imagine that people run remote sites that are hours of driving away… :unamused:


#8

yep but I was replying to the OP :wink:

Just reimage. Save yourself the time and effort of diagnosing the fault


#9

It seems that dump1090-fa has a problem, top says that it uses 100% CPU.

strace it and see if it’s something obvious? Not much else I can really suggest for wheezy, it’s getting old and creaky now.


#10

just out of curiosity, What version of Kernel are you running, there has been some users complaining about the new Kernel v4.9.x


#11

I am using 4.9.25-v7+ at the moment.


#12

On a pi2 or a pi3?

Might be worth downgrading the kernel to 4.5 if it’s a pi2 see if this fixes the issue.


#13

It’s a Pi2. I just downgraded to 4.4.50-v7+, so let’s see if it helps…

Thank you for the suggestion!


#14

Here is a thought. How about adding “ssh enable/disable” as a command on the stats page.

Not trying to be a smart a$$. I have done it all and still can’t get into my Raspberry Pi.


#15

See raspberrypi.org/documentati … ccess/ssh/ :

For headless setup, SSH can be enabled by placing a file named ssh, without any extension, onto the boot partition of the SD card. When the Pi boots, it looks for the ssh file. If it is found, SSH is enabled, and the file is deleted. The content of the file does not matter: it could contain text, or nothing at all.


#16

Is it not correct that I need to be able to get into the Raspberry Pi to do any of that.

All I get is port 22: connection refused.

BTW I am on OS X EL CAPITAN.


#17

I am in now. Changed the ssh to SSH in boot partition.


#18

Performed a re-image. Worked flawlessly. At first my SDCARD was locked and couldn’t image it, come to find out my SDCard Reader wouldn’t do the work as expected, had to use another. Fixed the .cfg file to reflect my internet and bingo. Added SSH file and connected no problem. Hope I stay connected for another 2 years without having to re-image again. Time will tell.

Mark Walsh