dump1090 mutabilty 1.15 dev


#1

Hi all
ive got myself stuck
installed version 1.15 but range colours target are not on my home address ie gps as stated by the rings
ive tried looking but not sure what to alter and where

john


#2

/etc/default/dump1090-mutability


#3

Thanks for pointing area i need
ive checked it and correct details already there ?

If set, supplies a reference location for local position decoding.

LAT="52.2475"
LON=“0.7103”

my target rings are correct but range colours are in germany


#4

look for config.js
In Joe’s scripts it is in
/home/pi/piaware_builder/package-jessie/dump1090/public_html/config.js


#5

thanks for reply

i did edit js with correct gps also show others but still in metric
but still dont move after a reboot
1 thing i dont run piaware on pi
would this be the problem ?

john


#6

What do you mean by “target rings” and “range colors”.
It will be easier to understand the problem and find a solution if you post a screenshot of your map.


#7

Yes i should have done that earlier

img prntscr.com/b9rczh

rings are located in uk range iis in netherlands

i have edited config.js with correct lat / lon

john


#8

@suffolk3000

Hi John!

This is really strange. Never seen this diplopia/squint in a dump1090 map!
I think the center marker of rings is your station location (Cambridge, UK), while range plot center is default location of marker (Amstardam, Netherlands)

I checked my config.js file in /usr/share/dump1090-mutability/html folder.
It shows the figures (45.0, 9.0) which are NOT my location, these are default values. Still I see eerything right on the map. My correct position values (43.5 & -79.6) are entered and stored in dump1090-mutability during configuration by command “sudo dpkg-reconfigure dump1090-mutability”. You also try this command and enter correct values during dump1090-mutability configuration dialogue, instead of editing any file. Then reboot the RPi.

My config.js file (part)




// – Map settings ----------------------------------------
// These settings are overridden by any position information
// provided by dump1090 itself. All positions are in decimal
// degrees.

// Default center of the map.
DefaultCenterLat = 45.0;
DefaultCenterLon = 9.0;
// The google maps zoom level, 0 - 16, lower is further out
DefaultZoomLvl = 7;

// Center marker. If dump1090 provides a receiver location,
// that location is used and these settings are ignored.

SiteShow = false; // true to show a center marker
SiteLat = 45.0; // position of the marker
SiteLon = 9.0;
SiteName = “My Radar Site”; // tooltip of the marker




SiteCircles = true; // true to show circles (only shown if the center marker is shown)


#9

John
When you installed dump1090-mutability 1.15~dev, was there already dump1090 or dump1090-mutability installed?
If this is the case, did you remove those by the following commands?



sudo dpkg -r dump1090
sudo dpkg -r dump1090-mutability


If you did not remove the existing one before installing the new one, then may be the presence of two versions of dump1090 is causing this squint/diplopia.


#10

Hi thanks for reply
i have checked it altered lat lon
and false for SiteShow = true; // true to show a center marker

i willreinstall it all later on im not getting the answer by editing


#11

no i started a fresh copy from scratch
but i will do same again im sure it will work properly

i dont currently use piaware but will inc it this time

its fun

john


#12

Well ive done a full clean install followed ( abcd567 How to Install dump1090-mutability_1.15~dev on RPi )

no problems on install

still comes up same problem
"spalt" is over netherlands

location pointed correct in uk

john


#13

Hi John!
No version of dump1090 gives the “coloured splashes” by default. It is the “coloured splashes” which are off centre. Did you follow liqmangua’s method to get these? If so check that procedure and post in that thread to get the answer.


#14

Ok i did the last bit FIND YOUR MAXIMUM POSSIBLE RANGE

and got the code

but still in netherlands

http://prntscr.com/bae7pj

dunno the mind boggles now

john


#15

The screenshot is not from my code. The height legend at the side is from something else. What did you install to get the range rings?


#16

Hi lignumaqua.
(1) I typed your name wrongly, sorry for that.
(2) I have tried your code only in the very early stages, then after a while my Pi crashed. I formatted and reinstalled OS and all, but did not try your code again. However I watched your code becoming more and more sophisticated, functional & colorful. This made me believe that the max range curves in screenshot posted by John were created by your code. Now it is John who can tell us what did he install to get all this.

However, (a)circular range rings & (b)terrain limit rings were created by the installation of dump109-mutability v1.15~dev, and these are aligned correctly to receiver position.


#17

Hi all

well i got short term memory loss so installed 1 tonight all ok working fine

jprochazka/adsb-receiver

im happy all is well
i think it was all the exciting colours of the extras i had i liked but 1 failed to stay at my location

never mind

i got the extra coloured addons from here
http://discussions.flightaware.com/ads-b-flight-tracking-f21/heatmap-range-altitude-view-for-dump1090-mutability-v1-15-t35844.html
i will have to use auto installs from now on much easier

im sorry i cannot remember where i got the details to install the extra displays

john


#18

the modified version of dump1090 from tedsluis requires a bit more work to get the range display working. it comes with an example range display and heatmap included, i’m guessing that’s what you saw. to get your own data, you’ll have to run some more scripts (found here: github.com/tedsluis/dump1090.socket30003) in the background to collect and prepare the data. the documentation is in the thread and the github repository, i suggest you dig into there, if you still wish to get it working.

I tried that version myself, but could not really see the big advantage and switched back to the “normal” mutability variant. to generate range plots i’m now using virtualradar server (vrs).


#19

Hi jketterl
thanks for reply
i have gotten futher today but not solved
thanks for the info

john


#20

hi suffolk 3000

I adopted Ted Sluis’ dump version also and had the same problems. I deactivated Ted’s heatmap as follows (in bold):

in config.js :
// User Map (KML File)
// Enables KML overlay on map, UserMap must have a value below when "true"
UserMapShow = false; //true to show KML

// User heatmap (csv File)
// Enables Heatmap on map
HeatmapShow = false; //true to show Heatmap

HeatmapFileSelector = false; //true to show file selector in heatmap panel.

In gmap.html I have deleted the entries for [Heatmap] and **.
But it seems for me, that Ted has written a new gmap.html, the actual looks different than that I’ve modified.

This should help you to hide the heatmap etc.

screenshot of my dump: http://manfredbischoff.homepage.t-online.de/screenshot_mb.jpg**