FlightAware Discussions

Dump1090 100%


#1

Hi,

After updating about 3 weeks ago (to 3.6.3) my dump1090 process (normally ca. 40% cpu) goes to 100% with an anomaly warning on my flight aware page and I get no aircraft detected. Weirdly this seems to happen at 02:00 (European time) every day. Piaware restarts dump1090 but this has no effect, only a reboot gets everything going again.

I’ve tried looking at logs, updating what I can, but I can’t find any culprit and nothing seems to work. Anyone with any ideas…?

Brian


#2

I’m sorry i don’t have any ideas besides trying a new image.

As a workaround though:

sudo crontab -e

Add the following line at the end:

10 2 * * * reboot -f

This will reboot the pi every night at 10 past 2.
You can check if the clock on the pi is running on your local time with the command

date

If it’s not you can either change the timezone in the Localisation Options after running the command:

sudo raspi-config

Or you just adjust the time of the reboot :slight_smile:

Good luck but i’m not sure how to fix the problem.

It would probably be sufficient to use (as root or with sudo)

pkill -9 dump1090-fa
systemctl restart dump1090-fa

When the problem occurs. But a reboot is simpler.

If you only want to reactively kill dump1090-fa and not just do it every night you could use the following little script
(Dump1090-fa stops sending messages after some time)

(piaware tries to restart dump1090-fa but it does not use brute force.
the script uses kill -9 which makes sure dump1090-fa is dead and then restarts it.)


#3

I’ll definitely try the 10 past 2 reboot in the crontab and see what happens, thanks.


#4

The link at the bottom is a better solution and not much more complicated actually :slight_smile:

I checked your stats and it seems the failure varies in timing somewhat.

Might i suggest you try a different power supply for the pi as well if you have one available?
That’s always good to check if these kinds of sporadic problems occur.