Anyone know how to stop FA's Dump1090 from starting


#1

so I can run OBJ’s version. Ive written one of the staff here, but have not heard back. Im a Linux Newb so my feeble searches for
the file to edit is coming up Not so good.


#2

Hi

I’ve had problems with this starting myself.

I tried deleting the rogue version and it comes back, so what I did was change the version that the fadump1090.sh service tries to start to the one I wanted.

In my case on Raspbian, I edited the /etc/init.d/fadump1090.sh file and changed the location of the dump1090 application. I commented the original line and added the second. In my case I feed FR24, so I use the Malcolm Robb version. See below:

#DAEMON=/usr/bin/dump1090
DAEMON=/usr/lib/fr24/mr-dump1090

I think another option is simply to disable that service. I installed ‘chkconfig’ (sudo apt-get install chkconfig *) and use that to stop the service running by typing ‘sudo chkconfig fadump1090.sh off’

I should say though I haven’t tried that one.

Hope that helps*


#3

Got 1090 stopped. That worked, just cant find the path to Mutability yet.


#4

Think I got it. PIAWARE-STATUS gives me

pi@raspberrypi ~ $ sudo piaware-status
dump1090 is not running.
faup1090 is not running.
piaware is running.
dump1090-mutab is listening for connections on port 30005.
dump1090-mutab is listening for connections on port 10001.
piaware is connected to port 10001.
piaware is connected to FlightAware.
dump1090-mutab is producing data on port 30005.
dump1090-mutab is producing data on port 10001.


#5

Looks good!


#6

Think Ill let it run for now to see what happens after a day or two before I try any changes :slight_smile:


#7

I also feed FR24, but I use FA’s version of dump1090. Why do you use the MR version?


#8

You can make fadump1090.sh non-executable with the following command:


sudo chmod -x /etc/init.d/fadump1090.sh

This leaves the file intact but takes away the ‘x’ flag (x is for eXecutable). Therefore, it cannot run and will not interfere with /etc/init.d/dump1090-mutability in the same directory.

If you want to restore the original setting and ‘x’ flag, use:


sudo chmod +x /etc/init.d/fadump1090.sh

Not sure if this best option to take in Linux but it’s simple and works for me :slight_smile:


#9

sudo update.rc-d dump1090 remove


#10

Didn’t work for me, but on googling it I think you just typo’d on the period and hyphen :slight_smile: So this one worked for me:


sudo update-rc.d dump1090 remove

Thanks!
I wonder if that means it’s finally gone… I’m sure it will return one day and annoy me though… :imp:


#11

I always do that :slight_smile: especially when downloading those armhf.deb packages. I switch a hyphen with an underscore. Sorry about that. You can use that command to turn off autostart of programs on boot and to enable it as well. But I assume you are using d1090-m which does that for you as long as you run dpkg-reconfigure.


#12

Thats the best option that worked for me. Everything is working nice now.


#13

I’ve followed those steps to stop the standard dump1090 from starting which seems to be successful, BUT piaware did not manage to restart dump1090-mutability by itself.

Any tips on how to make this happen?