FlightAware Discussions

Bad ADS-B Signal Level?

I have 4 Pi’s that are in a variety of locations with a variety of antennas and SDR’s. One of the SDR’s is the Orange FlightAware SDR. The others are all Nooelec Nano 3’s. Here’s the results:

Nooelec + FlightAware Antenna in an attic:
Screen Shot 2021-10-22 at 3.34.43 PM

Nooelec + Homemade Spider in an attic
Screen Shot 2021-10-22 at 3.34.32 PM

Nooelec + Cheap Aerial on a tin can
Screen Shot 2021-10-22 at 3.34.37 PM

Orange FlightAware stick + Nooelec High Gain
Screen Shot 2021-10-22 at 3.34.49 PM

Any idea why the signal for the Flight Aware SDR is do different than the other 3? Do I need a filter or something? Let me know if you need more information.

Thanks!

Please compare Scans 2 & 3 below. The comparison makes obvious the need for external filter.

A pretty realistic, wide-band scan covering the entire bandwidth of RTL based dongles.

Spektrum - How-to Speedily Scan RF Noise in band 24MHz ~ 1800MHz

 

The results of scans are below:

The scan 1 shows RF noise picked by antenna and processed without any filter , The scans 2 & 3 were done with filters, and show how filters remove this noise.

Scan 1 of 3 - FA Antenna + Generic DVB-T (no internal or external filter)

Thumb-Generic DVB-T

CLICK ON IMAGE TO SEE LARGER SIZE

Scan 2 of 3 - FA Antenna + ProStick Plus (Only Internal filter of ProStick Plus. No External filter)

image
CLICK ON IMAGE TO SEE LARGER SIZE

Scan 3 of 3 - FA Antenna + ProStick Plus (with internal filter) + External Filter (FA Light Blue)

imageimage
CLICK ON IMAGE TO SEE LARGER SIZE

1 Like

I’d the say the antenna is the issue.

Yes, very likely. Try FA Orange ProStick with home made spider to confirm.

NooElec ADS-B 8.5cm Antenna Bundle gain JOKE

 

 

Ok - I’ll try a different antenna. The spider is pretty inaccessible right now, but I have another “high gain” antenna that I’ve had success with before. I’ll give it a try tomorrow.

Yo can make Quick Spider. It is very easy to make and is made of coax only.

QUICK SPIDER - No Soldering, No Connector

 

Quick Spider made of RG6 coax

 

F-female to SMA-male pigtail to connect RG6 coax to the dongle

pigtail-F-female to SMA-male- RG316

 

pigtail-F-female to SMA-male- RG174

The obvious thing to do is to swap antennas (by rolling their coaxes) between one of the Nanos and the FlightAware stick and see if the problem follows the Nooelec antenna or the FA dongle. If the Nano with the Noolelec antenna has the same issue, it’s the antenna or the coax. The next step would be to roll the coaxes back at the dongles and roll them at the antennas instead to see if it’s the antenna itself or the one coax.

If the problem stays with the FA orange dongle, it’s the dongle, and as it contains an LNA your next step would be to experiment with reducing its gain in steps to find its sweet spot, unless you’re using dump1090-fa and have adaptive dynamic range enabled. If changing the gain doesn’t help, add a filter near the antenna and see if that helps (after setting the gain back to what it was.)

You can do the same thing with your Pis: swap dongles between the one that now has the FA stick and one of the others with a Nano in case it’s a Pi issue (which I think is unlikely, but anything’s possible.)

It’s just basic troubleshooting: sectionalize the problem, sectionalize it further within the bad section, etc. until you isolate the cause. If the problem comes clear during your troubleshooting changes it was probably due to a bad connection, either coax or USB, and you fixed it while changing things around.

If the two systems are at substantial distance apart, swaping coax may not be easy/practical.

A much easier solution is to swap dongles, keeping everything else in place.

Thanks for the feedback again. I swapped antennas and the problem certainly seemed to be that Nooelec “high gain” antenna. You can see on October 23rd what a difference it made. I got a week’s worth of data to reflect that. I’ll try a better spider and changing location next time I have access to the Pi.

Screen Shot 2021-11-02 at 8.12.04 AM