Automated Installation of ModeSMixer2 & ModeSDeco2 on RPi

For this folder to be used by modesmixer2, gives its ownership to the user which runs modesmixer2.

In case of installation by my script, this user is mm2. Therefore you have to issue following command to take over ownership of parent folder data.

The argument -R makes the ownership of folder data recurssive, i.e. all files, sub-folders, and files in sub-folders are also owned by mm2.

sudo chown -R mm2:mm2 /home/pi/data

1 Like

I wonder if ModeSmixer2 would except a in connect of data from UAT side of Piaware?

This is not feasible. Please see @obj and @sergsero comments in following thread:

Feed 1090ES + 978UAT to Different Sites

 

 

1 Like

Today i’ve tried to install the newer version of ModesMixer2 on my Raspberry 4 with DietPi installed in 64-bit

So far the installation went through and i edited the config file accordingly.
However whenever i try to start the service, it gives me this error:

inConnectId(192.168.2.109:10003:ADSB) can't resolve host 192.168.2.109 Service not found

The IP address including the port points to my Jetvision device and it’s correct for sure.
On the other Raspberry with Raspberry OS “Bullseye” the exact same configuration works without issues.

This is how it looks on my other Pi:

inConnectId(192.168.2.109:10003:ADSB) connected
inConnectId(192.168.2.109:10003:ADSB) BEAST data stream detected

The device is pingable using the IP address from that DietPI device.

Any ideas?

(1) Can you please provide full name of the modesmixer’s .tgz file? (check inside folder /usr/share/mm2/)

(2) Exactly which automated install script you used?

 

I was using the Raspberry 64bit script from your Github repository (Option 2)

sudo bash -c "$(wget -O - https://raw.githubusercontent.com/abcd567a/mm2/master/install-mm2-64bit.sh)"

I will try it again with a fresh installation of Raspberry OS 64-bit. I would assume it is something with DietPi

Update:

Tested on a fresh Raspi OS 64bit and it works:

ModeSMixer2 v.20210228 RPI_x64
inConnectId(192.168.2.109:10003:ADSB) connecting 192.168.2.109:10003
inConnectId(192.168.2.109:10003:ADSB) connected
inConnectId(192.168.2.109:10003:ADSB) BEAST data stream detected

So the error was coming from the DietPi instance. No desire to search for the error :wink:

This is what i mean with “newer version”:

image
image

Great. For me also the 64-bit ModeSMixer2 works OK on 64-bit Raspberry Pi OS Bullseye.

I just now finished writing latest 64-bit DietPi and installed modesmixer2 with the script you mentioned in your post. It gives same error as you mentioned

1 Like

Found solution of this issue by Sergsero (author of ModeSMixer2) in his June 2020 post in Radarspotting dot com forum

2 Likes

Thanks for checking it.

I really love DietPi for it’s efficiency but this messed me up :smiley:

2 Likes

Want to test 64-bit ver of piaware 7.1, dump1090-fa 7.1 & piaware-web 7.1 on RaspberryPi OS 64bit Bullseye or DietPi 64-bit Bullseye?

Follow instructions here

2 Likes

Thanks, i was already thinking about a new attempt over the weekend. Good timing.

 

For those who are not aware from where to download 64-bit Bullseye OS image:

64-bit RaspberryPi OS Bullseye (arm64 / aarch64)

https://downloads.raspberrypi.org/raspios_lite_arm64/images/raspios_lite_arm64-2021-11-08/

64-bit DietPi OS Bullseye (arm64 / aarch64)

https://dietpi.com/downloads/images/DietPi_RPi-ARMv8-Bullseye.7z

 

DietPi image installation instructions:

1 Like

Too much of Linux and ADSB… Just for some change and laugh :slight_smile:

2 Likes

The Video is blocked for users from Germany due to licensing issues :wink:

1 Like

Oh, you missed the laugh. It is a nice short comedy video. It is a German production. You might have watched it on TV.

1 Like

If you really want to see it set your VPN to a server outside Germany.

Its a documentary so not that funny. :wink:

S.

I know how that all works out. I just wanted to mention to @abcd567 that the Video is not working for everyone :wink:

1 Like

@foxhunter
@garry72

I have solved the problem of failure of ModeSMixer2 on DietPi :slight_smile:

In fact I have found this solution in May 2019 when I faced similar problem during installation of RB24 feeder on DietPi, but have forgotten this incident completely. Today when I installed RB24 feeder on DietPi and faced this problem, the incident flashed back in my memory, and with some little search in RB24 forum, I could find my post in which I have goven this solution.

sudo apt install netbase   

sudo systemctl restart mm2   

Seems in order to make DietPi slim, its makers have removed some essential packages also. The Raspberry Pi OS 64-bit has all the important packages, so no such issues there.

Before Installing Package netbase

After Installing Package netbase, & Restarting ModeSMixer2

2 Likes

ModeSMixer2 Installation script - Visitor’s traffic for last 14 days (March 19 to April 01, 2022)

Github provides Traffic statistics for last two weeks (visible only to owner of site).

https://github.com/abcd567a/mm2/blob/master/README.md

 

 

 

3 Likes