ModeSdeco2, modesmixer2 and piaware


#1

OK, for reasons known only to me, I have modesdeco and modesmixer2 running but want to feed my data to piaware. Which --outserver format and/or port do I need for piaware to pick up and feed the website? I have no intentions of running any form of dump1090 as the decoding software unless it is in the form of binary data pushed out by either modesdeco2 or modesmixer2.

Any help would be appreciated.

Michael
New Zealand


Anybody tried ModesDeco2 instead of PiAware?
#2

I believe recent versions of modesmixer2 directly support FATSV output; this is the format that piaware wants. You will need to run it on the same machine as piaware.
Alternatively, you can run faup1090 on the piaware machine pointing at a Beast-format data source.


#3

I’ve had a snoop around my Pi but don’t seem to be able to find faup. I assume it gets installed somewhere with piaware?


#4

Yes, it’s provided with the piaware package.
It’s usually started automatically by piaware if piaware sees a data source on port 30005, but of course that won’t happen in your case.
So you’ll probably need to start it manually with a --net-bo-ipaddr option pointing at your datasource. Once faup1090 is running, piaware should notice and feed data from it.


#5

Yep found it in /usr/bin and added a command to my startup script.

So with modesdeco2 and modesmixer2 the commands are:



cd /home/pi/modesdecode
/home/pi/modesdecode/modesdeco2 --gain 49.6 --freq-correction 85 --location -40.3:175.6 --web 8082 --beast 30005 --localtime > /dev/null &
sleep 5
/home/pi/modesmixer2/modesmixer2 --inConnect 192.168.1.5:30005 --outServer msg:30003 --outServer sbs10001:10002  --globes 31008:myrtl:NZPM &
sleep 5
sudo /usr/bin/faup1090 > /dev/null &


Seems to be working good!

Michael


#6

Looks good!

If you are running modesmixer2 on the pi, you can probably get rid of faup1090 if you can work out how to make modesmixer2 listen on port 10001 and provide FATSV output there.


#7

I tried that but piaware kept saying that there was nobody listening on 10001, hence the reason for this post :laughing:


#8

There is a bug in stock piaware where it will only notice processes bound to the wildcard address, not a specific network interface address, maybe that’s it?