AJAX Errors


#1

Running piaware 3.5 on a PI3 I constantly receive these two AJAX errors on Skyview map:


What happens is this. The map refreshes 1/s. During normal daytime periods of activity it will successfully refresh roughly 1 to 12 updates (i.e. 1 to 12 seconds) and then pause for 1-2s popping up one or both (in sequence) of these errors.

I initially thought dump1090 isn’t able to update json files as quickly as the map is trying to read them ( I earlier used dump1090-mutability and the update rate could be configured. I had it set at 2s cycles I think to avoid this sort of problem.) At this moment the behavior is occurring with 65 aircraft and a message rate of 200/s. The thing is, I have a piaware on a pi2 in another location that gets much better reception. It currently is showing 255 aircraft and a message rate of 900/s and the map updates fine with no errors. htop shows the load average of the receiver that updates fine as about 2x the problematic one. This makes me think it isn’t a problem with load on the receiver.

I thought maybe network was a problem (both receivers on wifi). iperf3 shows the problematic receiver has a good connection while the working one is actually on a slightly flaky connection. Latency to flightaware is around 50ms for both.

I thought perhaps there was a problem with file permissions but I can’t seem to find any nor can I see anything in piaware.conf or config.js that I would think is causing the problem.

Anyone have any ideas on what is causing this or and/or how to troubleshoot?


#2

Are you using a sdcard image or a package install?


#3

package


#4

Have you enabled the lighttpd config that disables the lighttpd stat-cache?
(the dump1090-fa package will try to do this, but you should verify it is present)

If the stat-cache is not disabled, lighttpd tends to return incorrect content-lengths if the underlying file is rapidly changing.


#5

Thank you! I added the following line:


server.stat-cache-engine    = "disable"

to the lighttpd config file (/etc/lighttpd/lighttpd.conf) and that fixed it!

When I switched from dump1090-mutability to dump1090-fa, I had to manually update lighttpd.conf so not surprising that something was missing.