Ajax error on my flightware pi system


#1

hey there i wonder if you could help me out.

im getting an ajax error on my radar screen and have no idea why?

im using a pi 3 system brought from modmypiwith flightaware softwear loaded onto a sd card,
the system is running the lastest update but yet the error still comes,

i have switched the network from wifi to cable but yet i still get the error.which can be seen below

could anyone point me in the right direction on how to fix thjis please,

many thanx

ben


#2

AJAX timeout errors generally indicate a network problem somewhere between your browser and the Pi.


#3

hey there and thank you for your reply,

i have tryed changing the cables but still to no effect i still get this error even using a brand new rj45


#4

try skyview on a different browser or machine - see what happens there …
and try to reboot your pi first


#5

hey there and thank you for your reply,

i have tryed using firefix, ie,crome and safi (moblie) and still i get the errors.

i have tryed it on 2 laptops 1 desktop and a windows server but i still get it :frowning:
ben


#6

if you have installed the gui on your raspi you could see if it works directly on the raspi. as obi already wrote - i saw this behavior only if something with the network went wrong …


#7

hey there and thank you for your reply,

i havnt installed anything to the pi 3 as everything i needed came already pre loaded,

i have checked my network and cant find any issues with it i have also contacted my isp for a line check and they have found no issues ithear,

i guess im stuck with this issue and just hope it sorts itsself out in due corse :frowning:
thank you all for your time and help on this matter have a great day

many thanx

ben


#8

ben,

if the problem remains i’d suggest you download the flightaware sd-card image here and install it to a different/second empty sd-card and see if that works.

sd-card-image: http://flightaware.com/adsb/piaware/build topic 2 Install PiAware on your SD card

your settings page: http://flightaware.com/adsb/stats/user/benfry71


#9

PiAware has a status screen if you go to the IP of the device.

Just remove the /dump1090-fa/ part at the end of the link.


#10

hello all and thank you for all your comments,

it turns out reinstalling the os and the flightaware softwear have fixed the timeout errors :slight_smile:
i am very greatful to you all for your time and help,

can i ask another qestion non related to this about updating or changing the standered map or do i need to open another topic

many thanx

ben


#12

just go ahead with next question :slight_smile:


#13

thank you for your reply :slight_smile:
im looking to update my map to something more earter to read like the map used on

https://global.adsbexchange.com/VirtualRadar/desktop.html

i would like the list to show the pics of the planes instead of flags and a hole lot of other stuff,

i have spent hours on google trying to find out how and so far still cant find an answer, however i have noticed other sites running the same version of the map.

so my qestion would be firstly is this possable?
secound where could i find this sort of map
and most inportantly how could i get this map onto my pi :frowning:
i am a total noob to all this so sorry for being such a pain,

many thanx

ben


#14

ben,

there is no way to change the map in skyview by just pressing a button. of course with coding skills in javascript/css/html you could alter the map and even layout of flightaware skyview.

most here in the forum use in addition to skyview virtualradarserver - another application to display the aircrafts on a map you find here - but i did not try this up to now: https://www.flightairmap.com

cheers
tom


#15

hey here and thank you for your reply :slight_smile:
i will check that link out,
are the map files stored on the pi system for the skyview map if i can find the map then i might beable to have a play around with it,

many thanx for your time and help

ben