FlightAware Discussions

Aircraft, Receiver, and Stats JSON Missing - Resolved

Piaware 4.0 SD-image
Rasbian Stretch

This image has been running for a few years without issue. Today only the status.json and piaware.pid file are being written to the /var/run/piaware directory. The /var/run/dump1090-fa cirectory has the a bunch of history_xx.json files as well as aircraft, receiver, and stats. Both directories are updating every few seconds.

I tried a workaround creating symlinks to the missing files via:
sudo ln -s /var/run/dump1090-fa/.json /var/run/piaware/.json,
then
sudo chown -h piaware:piaware .json to correct the permissions.

This successfully created the symlinks but there were not accessible via browser, returning 404.
I rebooted the unit and it is still not creating these files in the /var/run/piaware folder.

No configuration change, power event, crash, etc. occurred prior to this issue. The unit was rebooted on 2/20/2021 and was working properly afterwards.

The SD is not full or out of inodes:

pi@piaware:/var/run/dump1090-fa $ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/root 30G 7.3G 21G 26% /
devtmpfs 459M 0 459M 0% /dev
tmpfs 464M 8.0K 464M 1% /dev/shm
tmpfs 464M 38M 426M 9% /run
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 464M 0 464M 0% /sys/fs/cgroup
/dev/mmcblk0p1 43M 33M 11M 76% /boot
tmpfs 93M 8.0K 93M 1% /run/user/1000

pi@piaware:/var/run/dump1090-fa $ df -i
Filesystem Inodes IUsed IFree IUse% Mounted on
/dev/root 1904352 296264 1608088 16% /
devtmpfs 117386 399 116987 1% /dev
tmpfs 118538 6 118532 1% /dev/shm
tmpfs 118538 1460 117078 2% /run
tmpfs 118538 6 118532 1% /run/lock
tmpfs 118538 12 118526 1% /sys/fs/cgroup
/dev/mmcblk0p1 0 0 0 - /boot
tmpfs 118538 18 118520 1% /run/user/1000

Those files are intended to be in those directories you mentioned. dump1090-fa creates aircraft.json/history.json files and stores them in /var/run/dump1090-fa/ which SkyAware consumes from.

Are you seeing an issue?

I have been using dump1090exporter for over a year without issue and it is looking for aircraft.json at localhost:8080/aircraft.json. Starting sometime today it is just spewing messages that it cannot find that file. Navigating on browser to piaware.lan:8080/aircraft.json produces a 404 error. Skyaware is working fine.

Sorry for the static. I changed the config to look at the local file instead of http and it is working again. No idea why I can’t access the files via http anymore, but for my purposes it is working again. Thanks.

You’re using the wrong URL path (should be /data/aircraft.json not /aircraft.json).

This has not changed in dump1090-fa for a long long time (back to at least 2016, I stopped looking further back in history at that point)