Active Display Software with RPi


#1

Hello all,

Does anyone use the GAS Active Display Software?

I ask because, prior to becoming a FlightAware feeder and using an RPi. I just used to feed FR24, using RTL1090, FR24 Feeder, Virtual Radar Server and Active Display, all running and working perfectly from my PC.

However, now I am using an RPi feeding FlightAware. I am able to use Virtual Radar Server without any problems but I cannot configure Active Display to work. I’ve tried my RPi ISP address, I’ve tried my NTWRK address, I’ve also tried the local address (127.0.0.1) and all ports between 30000 and 30003 but nothing seems to be working.

What I am attempting to achieve, is to Auto Populate my Basestation.sql file that is being written to by the Virtual Radar Server.

Any ideas?

Thanks :smiley:


#2

If the software is expecting BaseStation format (which is what a quick Google tells me) and it’s on your local network then you would use your local network address of the Pi and port 30003. Whatever IP you are using for VRS will be correct.
Port 30005 is BEAST output as an alternative if the software supports that format.

127.0.0.1 is localhost so that only works if the software is on the same machine, which it’s not since it’s on your Pi.

Not familiar with the software so can’t suggest much more beyond that.


#3

Hi Adraenyse,

Thanks for your reply but it still doesn’t want to play, even after trying your suggestion.

My Pi IP is xxx.xxx.0.5 and Virtual Radar Server is set to same IP address with Port 30002 with Data Source AVR or Raw Beast.

I’ve even tried creating a Rebroadcast Server in Virtual Radar Display with Format - BaseStation and Port 33001.

I’ll try and see if the Software Developer can shed any light on this :unamused:


#4

Hi Adraenyse,

All working fine now. I was trying Active Display Lite instead of Active Display Pro and I remember that Pro does things that Lite couldn’t.

Now my BaseStation database is all nicely up-to-date :slight_smile:


#5

Of course it didn’t just tell you that, you had to figure it out on your own. Silly licence restrictions not making themselves clear.


#6

So is Active Display Pro the only way I can get the databases to update? I’ve tried lite and SBS-1 Populate and neither want to do the job. Just want to make sure it’s worth the license.


#7

Hi Jim,

SBS-1 Populate was taken offline by GAS early last year. It will still read your information but it won’t update your BaseStation database.

As for Active Display Lite - It doesn’t populate your datebase properly, as it keeps stopping and starting, even with the BaseStation exe file running.

Best bet is Active Display Pro. As it doesn’t need any other software running except Virtual Radar Server. Virtual Radar Server writes to the BaseStation.sqb file and Active Display Pro; reads your BaseStation.sqb file, searches GAS Database, Auto-populates and updates your database.

Ask GAS for a month’s trial and you’ll see the benefits straight away. After that, you could subscribe.

Email GAS Support here: adlicensing@gatwickaviationsociety.org.uk

I am very happy with Active Display Pro, as I am seeing many new (Seen 1) aircraft daily :slight_smile:


#8

SOLD!


#9

Good on ya Jim :slight_smile:

I did edit with the email addy. Not sure if you spotted it. I’ll put it here, unless you already know it.

Email: adlicensing@gatwickaviationsociety.org.uk

I just emailed them to let them know you’re interested. I don’t gain anything, just advising them to look out for your email, as when I first contacted them, my email went into the bulk folder :unamused:


#10

Having a slight problem. I’m autopopulating but getting random:

“SD22 Rights for new session cannot be found. Please (re)start Basestation software.”

I’m having VRS connect to the Basestation format port on the pi. I have tried the Beast format too and get the same error.

Thoughts?


#11

Hi Jim,

Check these settings please. Do not use Basestation port 33001.

Set your receiver Data Feed, Data Source in VRS to AVR or Raw Beast Feed. Then Network, your Pi Address on Port 30002.

Make sure your VRS is writing to the BaseStation.sqb file correctly and that Active Display is pointing to the same file too.

Also, your Pi picks up everything that is airborne, whilst FlightAware only shows you Passenger Aircraft. So, when ADPro starts “Catching-up” it will populate everything you have recorded/saved. Thus: passenger Aircraft, Military Aircraft, Biz Jets, Light Aircraft, Helicopters etc. hence all the different colors.

Hope that helps.


#12

Well… I made the changes and it ran like a charm for 10 minutes. Now I’m back to the ActiveDisplay display clearing and getting a new error:

SD22 Rights for new Session cannot be found. Please (re)start Basestation
Object reference not set to an instance of an object

I can go into the display and do a bulk populate of the unknowns but AD never starts back up.

Thoughts?