404 Not Found - PiAware Issue


#1

My PiAware unit is active but when I try to view the data the 192.168.1.xxx, everything is showing green with no issues present.

When i ssh into the pi, the status shows everything is working fine and sending data. I have checked my stats page and the unit is live. I also have a couple of other feeders running and they are also receiving/sending data normally.

Any advise is appreciated in resolving this issue.


#2

What happens when you click the “view live data” link here? flightaware.com/adsb/stats/user/smee56

Are you trying to connect from on the network?


#3

Port 8080 returns no data, unable to connect.


#4

Just now

  1. Formatted microSD card

  2. Wrote ARMBIAN 5.25 (Debian) image to the microSD card

  3. Inserted card in Orange Pi PC

  4. Installed Piaware and dump1090-fa as per instructions on this page:
    flightaware.com/adsb/piaware/install

  5. In file /etc/modprobe.d/rtl-sdr-blacklist.conf, added the lines below, and rebooted.
    blacklist dvb_usb_rtl2832u
    blacklist dvb_usb

  6. Checked, dump1090-fa and Piaware working OK.

  7. Checked Flightaware stats page shows ok
    flightaware.com/adsb/stats/user/ … stats-5252

  8. Checked local map. NOTHING on 192.168.0.23, 192.168.0.23:8080, and 192.168.0.23/dump1090-fa

NO SOFTWARE OTHER THAN MENTIONED ABOVE IS INSTALLED.

dump1090-fa Status - OK

Piaware Status - OK

:8080 - Nothing

/dump1090-fa - Nothing
https://s20.postimg.org/6jt8p1ad9/Orangr_Pi_-unable_to_connect-_dump1090-fa.png

- Nothing
https://s20.postimg.org/l4abjv5bx/Orange_Pi_-unable_to_connect-_no_port.png


#5

I guess that your orange pi distro does not install lighttpd by default, or it is set up in a way that does not play nicely with the config fragments that dump1090-fa supplies.


#6

Thanks obj.
Tried to install lighttpd, seems it is already installed.
Now will format the microSD card and will write the older version of Armbian which I have been using successfully, and report the outcome.



pi@orangepipc:~$ sudo apt-get install lighttpd
Reading package lists... Done
Building dependency tree
Reading state information... Done
lighttpd is already the newest version.
lighttpd set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
pi@orangepipc:~$


Edit: This is the current distro installed:



___                               ____  _   ____   ____
 / _ \ _ __ __ _ _ __   __ _  ___  |  _ \(_) |  _ \ / ___|
| | | | '__/ _` | '_ \ / _` |/ _ \ | |_) | | | |_) | |
| |_| | | | (_| | | | | (_| |  __/ |  __/| | |  __/| |___
 \___/|_|  \__,_|_| |_|\__, |\___| |_|   |_| |_|    \____|
                       |___/                     

Welcome to ARMBIAN 5.25 stable Debian GNU/Linux 8 (jessie) 3.4.113-sun8i
System load:   0.49             Up time:       10 hours
Memory usage:  7 % of 1000Mb    IP:            192.168.0.23
CPU temp:      41°C
Usage of /:    16% of 7.2G

Last login: Mon May  1 13:54:41 2017 from 192.168.0.11
pi@orangepipc:~$ uname -a
Linux orangepipc 3.4.113-sun8i #10 SMP PREEMPT Thu Feb 23 19:55:00 CET 2017 armv7l GNU/Linux
pi@orangepipc:~$



#7

If lighttpd is installed but you’re getting connection refused on port 80, perhaps lighttpd is not configured to start automatically?


#8

Tried to start lighttpd, no success.

pi@orangepipc:~ sudo systemctl restart lighttpd pi@orangepipc:~ sudo systemctl status lighttpd -l
● lighttpd.service - Lighttpd Daemon
Loaded: loaded (/ lib / systemd / system / lighttpd.service; enabled)
Active: failed (Result: exit-code) since Mon 2017-05-01 15:42:43 CEST; 40s ago
Process: 917 ExecStart=/usr/sbin/lighttpd -D -f / etc / lighttpd / lighttpd.conf (code=exited, status=255)
Process: 909 ExecStartPre= / usr / sbin / lighttpd -t -f / etc / lighttpd / lighttpd.conf (code=exited, status=0 / SUCCESS)
Main PID: 917 (code=exited, status=255)

May 01 15:42:42 orangepipc lighttpd[909]: Syntax OK
May 01 15:42:43 orangepipc systemd[1]: Started Lighttpd Daemon.
May 01 15:42:43 orangepipc lighttpd[917]: 2017-05-01 15:42:43: (log.c.118) opening errorlog ’ / var / log / lighttpd / error.log’ failed: No such file or directory
May 01 15:42:43 orangepipc systemd[1]: lighttpd.service: main process exited, code=exited, status=255 / n / a
May 01 15:42:43 orangepipc systemd[1]: Unit lighttpd.service entered failed state.
pi@orangepipc:~$

Tried this, no success.
Will now revert to older version which I have been using successfully (Armbian_5.20_Orangepipc_Debian_jessie_3.4.112_desktop)



pi@orangepipc:~$ sudo lighty-enable-mod dump1090-fa
already enabled
Run / etc / init.d / lighttpd force-reload to enable changes
pi@orangepipc:~$ sudo / etc / init.d / lighttpd force-reload
 ok ] Reloading lighttpd configuration (via systemctl): lighttpd.service.
pi@orangepipc:~$


NOTE: Added spaces before and after slashes / to cheat “Forbidden, you dont have permission to post”


#9

UPDATE:
Wrote image of older, tested version (Armbian_5.20_Orangepipc_Debian_jessie_3.4.112_desktop)
The “192.168.0.23:8080” and “192.168.0.23/dump1090-fa” work OK.

The “192.168.0.23” and “192.168.0.23:80” bring lighttpd’s Placeholder page, instead of Piaware Radio Status page.
Tried changes shown in red below

sudo nano /etc/lighttpd/lighttpd.conf

#server.document-root = "/var/www/html"
server.document-root = “/usr/share/dump1090-fa/html”

After changes and reboot, the “192.168.0.23” and “192.168.0.23:80” started displaying Skyview page with yellow warning box: “Problem fetching data from dump1090”. The “192.168.0.23:8080” and “192.168.0.23/dump1090-fa” still working OK.


#10

What are you trying to achieve? It is not a surprise that if you misconfigure the webserver, it doesn’t work.


#11

I think following will provide the required clarification:

(1) The configuration changes were made only when I reverted to older and tried version of Armbian (Armbian_5.20_Orangepipc_Debian_jessie_3.4.112_desktop).

(2) The reason I made changes to configuration file /etc/lighttpd/lighttpd.conf is that the Piaware Radio Status page was not shown on “192.168.0.23” or “192.168.0.23:80”. Instead lighttpd’s Placeholder page was shown. I was trying to bring the Piaware Radio Status page.

(3) The configuration changes did not affect the pages “192.168.0.23:8080” and “192.168.0.23/dump1090-fa” These worked OK and displayed Skyview page with aeroplanes, both before and after configuration changes.

(4) When I changed the configuration, the Piaware Radio Status page still did not show on “192.168.0.23” or “192.168.0.23:80”. I have therefore removed the configuration changes I made manually in file /etc/lighttpd/lighttpd.conf.

In the older version (Armbian_5.20_Orangepipc_Debian_jessie_3.4.112_desktop), the Skyview map is working OK.


#12

The top-level status page is only present on piaware sdcard installs.

If you want to install it on something else, try installing the piaware-web package (but it will take over the top-level page, and it assumes it is running on a sdcard image, so YMMV)


#13

I am having the same issues. I haven’t done anything custom and it was working on version 3.3. After the upgrade, I am no longer able to see my dump 1090 map. The error message on the browser is “connection refused”

Edit, so I tried updating the packages again. Nothing updated but I was suddenly able to see the map. However, my whole system stopped receiving messages (and the map had the old data warning and was frozen). The restarts from my ads-b page were not fixing this problem. I had to fully halt the device and after plugging everything back in, everything seems normal. So not a smooth update, but we are back in business!