15 results in Enroute


#1

I run SetMaximumResultSize with param: 100, but when i run Enroute “KSLC”, 50, i still recieve 15 results… is there a problem?


#2

Works for me in Python… I’ve checked your user account and we’ve definitely received a successful call to set your account’s maximum length limit to 100 already.

Try checking that you’re passing all of the arguments to Enroute() properly. It’s possible that your SOAP client is not forming the request properly.


#!/usr/bin/python

# https://fedorahosted.org/suds/
# Suds 0.3.3 or higher
# yum install python-suds

import sys
from suds import null, WebFault
from suds.client import Client

username = 'YOUR-USERNAME'
apiKey = 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx'

url = 'http://flightxml.flightaware.com/soap/FlightXML2/wsdl'

api = Client(url, username=username, password=apiKey)

result = api.service.SetMaximumResultSize(100)

for x in range(10,50,10):
    result = api.service.Enroute('KSLC', x, '', 0)
    print "Got %d results with nextoffset %d when I requested %d" % ( len(result.enroute), result.next_offset, x )



Output is:

./tester.py
Got 9 results with nextoffset 10 when I requested 10
Got 19 results with nextoffset 20 when I requested 20
Got 28 results with nextoffset 30 when I requested 30
Got 38 results with nextoffset 40 when I requested 40