What's going on with my setup?

My setup used to be a RPi → FA dongle → Bias T → short coax cable → LNA - FA antenna.
At some point my receptions/results were going all over the place.
I didn’t know what caused it and didn’t really wanted to look into it, so I just plugged in the old DVB-T stick with DVB-T antenna and called it a day…a loooong time ago.
Still poor reception (bad antenna inside) but at least consistent results.

Having a good antenna on the roof and not using it, is a shame so this Saturday I plugged it in again.
This time with the bias t fed with a USB splitter (from the official RPi power supply) instead of feeding the LNA from the RPi pin headers.

Still, not good:

Results are going all over the place.
Yesterday at one point on Skyaware/Tar1090 it was showing 100+ aircraft with about the same positions.
But most of the time it shows around the same amount of aircraft, but with no (or maybe a few) positions.

I haven’t looked into the firmware/software in months/years since it just kept working and I never thought about it. Recently I did update PiAware but the firmware/software was so old I had to do it manually (instead of doing it throught FA’s website)

I should probably climb up the roof to check the antenna/LNA and connections but the weather is bad lately (rain, snow, wind etc.). That’s besides the point I hate going up there:

TLDR: does anyone have an idea what the problem is with my setup? Is it firmware/software, faulty connections or outright broken hardware? Or?

Some questions:

What is the version of your software at the moment ?
Piaware version ?
What cable are you using ?
What is your gain setting ?

It looks like you are overloading the system some way so that might be a starting point to investigate.

PiAware 8.2.

I can’t find the exact listing/cable anymore, but it’s a short piece (maybe 2 meters or so) with connectors already on it (haven’t put the connectors on it myself)

I’m using the automatic gain script: Automatic gain optimization for readsb and dump1090 fa · wiedehopf/adsb-scripts Wiki · GitHub

Logs tell me it’s currently at 43.9.

Any direction where to look (for)?
I haven’t looked into ADS-B for a long while; so I’m not up to date with all the latest scripts and do’s or dont’s…

This is the last 2 hours:

43.9 is quite high when also using an LNA I think (but maybe some of the other guys know better, I don’t have an LNA in my setups). would it be possible to get the LNA out of the chain to see what it is doing without it so you can determine step by step if you have faulty hardware in the chain ?
The jumping of the range plot isn’t right, that should be much more stable.


wonder if it’s the LNA. It could be crapping out. I know it’s a PITA but you may want to take it out of the picture and see if that solves the problem. (and obviously unplug the bias t at the same time)
(oh man, I replied and then realized that @tomvdhorst just said the same thing…)

The gain is set way too high. The range is very tight and too close to -3db. Tracks with Single messages is also way too high.

Lower it by 10 or 20 to get a better db range.

1 Like

remove the script

sudo bash -c "$(wget -nv -O - https://github.com/wiedehopf/adsb-scripts/raw/master/autogain-remove.sh)"

Then adjust the gain

Setting the gain manually,it depends if you have the package installation or working with the SD card image installation

Automatic gain can be usefull but that might be to high to your liking.
Set the gain manually and wait 24 hrs to see if there is an improvement or a decline in your reception.
Don’t expect wonders, autogain checks once per hour to see if the value is still correct but it seems to be quite steady in your set-up.

Don’t you see any aircraft with the filter added ? It seems it filters out some noise in your graphs but the noise figure is already low

Supported gain values (29):
0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6

For the package installation

sudo nano /etc/default/dump1090-fa

Scroll down and change these two lines

RECEIVER_GAIN=60 → Change this figure to to the number you want
ADAPTIVE_DYNAMIC_RANGE=yes → Change yes to no

then restart dump1090-fa

sudo systemctl restart dump1090-fa

For the SD card image

sudo piaware-config adaptive-dynamic-range no

sudo piaware-config rtlsdr-gain (number you want to set)

sudo systemctl restart piaware

sudo systemctl restart dump1090-fa

Hi, after looking at your picture of the aerial, I would move it higher as where you clamp it to the pole should be the only bit of the aerial that does not have a 360 view. You might be stopping signals as your aerial is too far down the pole.


My aerial pic


1 Like

Old radio guy here. Your antenna is very close to the mast and that will detune the antenna from the 1090 MHz resonance. craigtrex600 above points this out well. The dark color of the mast implies either metal or the gray PVC pipe usually used for underground power cable runs.

And generally, the FA Dongle (Blue dongle is specific to 1090 MHz and includes an internal LNA and filter. Orange dongle contains an wide band LNA and no internal filter), as such, you probably do not need the BiasT nor extra LNA.

One quick test would be to take the external LNA out of the system, connecting the antenna to the FA Dongle with your existing coax cable. This will help you identify if the external LNA is helping or hurting your results. We have all gone through these same trials and experiments to get our systems up and running. Have fun, and learn.


1 Like

So I removed the autogain script and set it manually to 25. (I followed @tomvdhorst entire post).
That results in about 165 aircraft and 140-150 with positions.
So it’s better, but that may be temporary. So I will leave it at that and check tomorrow or so to see how it’s going.

But if the gain is set way to high; shouldn’t the autogain script correct it automatically?

As for the mast; I had no problems with it before. Picture of the mast (and internal hardware) was taken on December 11 and 12, 2020. Most likely, that was the time I installed the Bias T and LNA on the current mast. (Visible in graphs below)
I installed LNA with Bias T since that was recommended at the time.

Setup was running great until ~August 2021; results plummeted around August 2021).
(Yeah, I should have looked in to this problem loooong ago :roll_eyes:)

Hardware inside was this, directly under antenna. You can see the coax go out on top of the image.
Looks like I replaced the phone charger with the official RPi power supply around August 2021 (as seen in my email-history) and last Saturday I placed used a USB-splitter to power the RPi and Bias T.
(So no more thin cable from RPi pin header to Bias T)

Old situation was without LNA and Bias T on a slightly shorter mast.
When updating I placed a slightly longer mast, so the antenna would be a bit higher (I can’t remember if the antenna was partly below rooftop with older lower mast), but I ended up not placing the antenna on top of the mast since I was a bit “wavy” in high winds or cable was slightly to short.
Don’t know which reason, since it’s been 2+ years ago.
Both masts are indeed PVC.

1 Like

Check tomorrow if your percentage of messages > 3 db is staying around 5%. That is a value you might be aiming for. I notice you are using the yellow Flightaware stick. That doesn’t have a filter built-in. If your values are staying as expected then you might want to add a barrel filter from Flightaware so you can filter out unwanted signals that are close to the Flightaware stick. Mobile phone signals can be greatly reduced by using the filter. :wink:

The autogain script isn’t aware of the presence of an LNA so it doesn’t take that into the optimization of the signal strength.
The wiedehopf script only corrects once per 24 hrs so that isn’ very often.

1 Like

Well, it has been a day and adjusting gain/removing automatic gain did make a big difference.

Here are the results for the last 24 hours:

I checked Skyaware/Tar1090 a couple of times today and saw a lot more aircraft, and about as much positions as aircraft.
(Weirdly though; my stats don’t show a massive improvement in total aircraft seen; it was around 1600-1700 per day and the today is was 2600.
See: Iemand91 ADS-B Feeder Statistics - FlightAware

You mean the red part in the top graph? Looks like that’s not going well…
Does that mean I have to lower the gain some more or go higher?

Yes, I do have the old (light)blue FA filter. (I think I removed it when I installed the LNA, maybe because with LNA filter was not needed…or something. Can’t remember; it’s been years since I last looked into ADS-B tracking. Stuff was just running and never paid attention to it.
Should I use it again (between FA stick and Bias T)?

I get that the script isn’t aware of the LNA, but thought it just looked at the incoming signal and (if needed) adjusted gain. Again, my knowledge about this has gone away mostly.

okay you have found the issue ( too high input values leads to overpowering the dongle) so now you can start working to get a better balance.

Most noticeable effect will be in the number of postions and range, not in the total number of aircraft. There are not that much more aircraft in your range on a daily basis. I get an avarage om 23-2400 per day and I’m in the same country :wink:

Every aircraft is only counted once per 24 hrs even if it makes multiple flights the same day.
For example, a Lifeliner Medivac helicopter can make 10 flights a day and all the postions of that flights will be counted but it only increases the aircraft count with 1 aircraft.
That’s why the postion number will always be higher then the aicraft count.

The red part in the top graph is still too high indeed. In order to get that right you need to reduce the gain .
I’d advice to reduce the gain to a setting of 15.7 or 16.6 and check again after 24 hrs.
Use the procedure you used yesterday.
If the number doesn’t drop down to around 5% you might want to reduce an additional step. Take one or max 2 steps at a time and check 24 hours later to see the value.

There will be a break even point where you can’t improve any more so then you will have to make a choice to either sacrifice range or lose some aircraft.
I have some feeders that have a percentage of 3 % and others on 10% strong messages.
5% would be optimal but you can tune that to your own liking when adjusting.

In regard to the filter, the correct place would be between the FA stick and the Bias-T.
The LNA enhances all signals and you only want to get the ADS-B signals to the FA stick.

Watch the effect of the fliter on your reception and decide if you want to keep using it. Normally a filter will improve the number of postions and it will give you less aircraft with only one position.
That will be visible in the graph on the right below the strong messages graph. The green number would get closer to the red spikes in the graph.

1 Like

Thanks man, great information!

I reduced gain to 15.7 and will check tomorrow for results.

I’m just happy that is seems not to be hardware failure but simply minor gain tweaking.
knock on wood…

1 Like

Let’s see what tomorrow brings :wink:

Last 48 hours:

You could reduce to 12.5 for the next 24 hrs. Then show the 24 hr graph. Your numbers on the page are rising nicely :+1:t2: Let’s how far you can step down in order to get close to the 5%

1 Like

What software are you using to make these graphs? (Edit – see post directly below – I figured it out)

oh damn. I always saw this and never installed it. And I just did on both of my setups and wondered how I could have gone without graphs1090!
Graphs1090 on Github
This is an amazing piece of software. now I’m going to have to see if I need to adjust down my gain – i got the first data point in and it’s 10%, but it’s only 1 data point. but I do have LNAs on both of my setups.

Thanks to @tomvdhorst and @Iemand91 for unknowingly giving me hours more of fun. :grinning:

Edit: So far on both setups 17% of messages >3. Autogain set at 42.1. So I got some work to do if it stays that way- - this thread is really helpful in telling me what to do.

1 Like