Upgrade PiAware from 2 to 3


#1

I attempted to upgrade my PiAware from 2 to 3. Running the upgrade command from the Configure window produced the following log messages. At the end, was was back to 2.1-2.

Really hate to lose a 1077+ day streak at year end when V2 is not supported anymore. Doing an SD image upgrade is not possible, since I run other software on the Pi.

[2017-12-27 07:24 CST] manual update (user-initiated via their flightaware control page) requested by adept server
[2017-12-27 07:24 CST] manualUpdate in adept config is enabled, allowing update
[2017-12-27 07:24 CST] performing manual update, action: piaware
[2017-12-27 07:24 CST] got status ok trying to fetch https://flightaware.com/adsb/piaware/files/latest
[2017-12-27 07:24 CST] considering upgrading piaware from https://flightaware.com/adsb/piaware/files/piaware_3.5-3_armhf.deb
[2017-12-27 07:24 CST] fetching latest piaware version from https://flightaware.com/adsb/piaware/files/piaware_3.5-3_armhf.deb
[2017-12-27 07:26 CST] 5897 msgs recv’d from dump1090-mutab (2186 in last 5m); 4896 msgs sent to FlightAware
[2017-12-27 07:31 CST] ====== successful login from piaware 2.1-2 from 73.44.61.36 ======
[2017-12-27 07:31 CST] lost connection to dump1090-mutab via faup1090
[2017-12-27 07:31 CST] reconnecting to dump1090-mutab
[2017-12-27 07:31 CST] ADS-B data program ‘dump1090-mutab’ is listening on port 30005, so far so good
[2017-12-27 07:31 CST] Starting faup1090: /usr/bin/faup1090 --net-bo-ipaddr localhost --net-bo-port 30005 --lat 42.036 --lon -88.054
[2017-12-27 07:31 CST] Started faup1090 (pid 2624) to connect to dump1090-mutab
[2017-12-27 07:31 CST] 7919 msgs recv’d from dump1090-mutab (2022 in last 5m); 5791 msgs sent to FlightAware
[2017-12-27 07:35 CST] installing piaware…
[2017-12-27 07:35 CST] *** running command ‘dpkg --force-confnew -i /tmp/piaware_3.5-3_armhf.deb’ and logging output
[2017-12-27 07:35 CST] > (Reading database … 80729 files and directories currently installed.)
[2017-12-27 07:35 CST] > Preparing to replace piaware 2.1-2 (using /tmp/piaware_3.5-3_armhf.deb) …
[2017-12-27 07:35 CST] > Unpacking replacement piaware …
[2017-12-27 07:35 CST] *** error closing pipeline to command: dpkg-deb (subprocess): cannot copy archive member from ‘/tmp/piaware_3.5-3_armhf.deb’ to decompressor pipe: unexpected end of file or stream\ndpkg-deb: error: subprocess paste returned error exit status 2\ndpkg: error processing /tmp/piaware_3.5-3_armhf.deb (–install):\n cannot copy extracted data for ‘./usr/lib/piaware/helpers/libpython3.2mu.so.1.0’ to ‘/usr/lib/piaware/helpers/libpython3.2mu.so.1.0.dpkg-new’: unexpected end of file or stream\nErrors were encountered while processing:\n /tmp/piaware_3.5-3_armhf.deb, continuing…
[2017-12-27 07:35 CST] installing any required dependencies
[2017-12-27 07:35 CST] *** running command ‘apt-get install -fy’ and logging output
[2017-12-27 07:35 CST] > Reading package lists…
[2017-12-27 07:35 CST] > Building dependency tree…
[2017-12-27 07:35 CST] > Reading state information…
[2017-12-27 07:35 CST] > 0 upgraded, 0 newly installed, 0 to remove and 14 not upgraded.
[2017-12-27 07:35 CST] > 1 not fully installed or removed.
[2017-12-27 07:35 CST] > After this operation, 0 B of additional disk space will be used.
[2017-12-27 07:35 CST] > Setting up pfclient (3.5.461) …
[2017-12-27 07:35 CST] > Starting pfclient: pfclient/usr/bin/pfclient already running.
[2017-12-27 07:35 CST] > failed!
[2017-12-27 07:35 CST] *** error closing pipeline to command: dpkg: error processing pfclient (–configure):\n subprocess installed post-installation script returned error exit status 1\nErrors were encountered while processing:\n pfclient\nE: Sub-process /usr/bin/dpkg returned an error code (1), continuing…
[2017-12-27 07:35 CST] upgrade of piaware complete.
[2017-12-27 07:35 CST] update request complete
[2017-12-27 07:35 CST] restarting piaware. hopefully i’ll be right back…
[2017-12-27 07:35 CST] piaware (process 2104) is shutting down because it received a shutdown signal (SIGTERM) from the system…
[2017-12-27 07:35 CST] piaware (process 2104) is exiting…
[2017-12-27 07:35 CST] ====== successful login from piaware 2.1-2 from 73.44.61.36 ======
[2017-12-27 07:35 CST] ADS-B data program ‘dump1090-mutab’ is listening on port 30005, so far so good
[2017-12-27 07:35 CST] Starting faup1090: /usr/bin/faup1090 --net-bo-ipaddr localhost --net-bo-port 30005 --lat 42.036 --lon -88.054
[2017-12-27 07:35 CST] Started faup1090 (pid 2702) to connect to dump1090-mutab
[2017-12-27 07:36 CST] 239 msgs recv’d from dump1090-mutab; 239 msgs sent to FlightAware


#2

Tried the upgrade again, and now it appeared to take. Running 3.5.3.

Feeder Type: PiAware (Debian Package Add-on) 3.5.3

Moderator: Feel free to delete this thread.