FlightAware Discussions

Updating local DB

Precisely, and only a reboot would fix it but it would only run for another couple of hours then hang again. As soon as I put the old json files but it continued running fine.

Unfortunately, I had other, more pressing personal issue to deal with and put it on hold.

I can test your script later today where i have SSH access to my box.

You had to reboot the RPi?

Are you talking VRS here or dump1090-fa?
Lighttpd can’t crash because of the json files it is serving (or it shouldn’t).

The next question is how complete is my database? Just because my VRS database is 25 gigabytes doesn’t mean I have information about every 'plane on the planet.

It would be great if there is a way of building a global database by collecting information from other VRS users.

FA member Keithma was interested in updating his Dump1090-FA database and sent me an export of his VRS database as he ‘sees’ way more planes than me due to his location. Maybe he can help make a start.

I think the Dump1090 process itself hung because there was just a blank map and nothing showing as being received in the graphs or on FA or FlightRadar for the period it wasn’t working.

As I said, I wasn’t able to devote any time to fixing it at the time.

That’s very strange, anyway try the commands i listed, it’s your database processed.

No need to recompile dump1090 (which could have been the source of your problem).

Well it was a few months ago when it choked and there have been changes made since then so I was going to try again now that the dust has settled. This thread gave me the prod that I needed.:grinning:

I’ll certainly give yours a try and see what happens.

Yeah i’ve also removed the quotation marks you talked about.
I’m curious, how do you get the type and registration just by the aircraft flying by?

VRS has a built in online lookup that queries http://planebase.biz/

This has to be entirely unrelated to any changes to the json db, because the json db is not used at all by the dump1090 process.

OH, I sit corrected.

Any feelings about what would have caused my problem then?

Why would replacing the original json files get it working again? I put the updated json files on both of my feeders and they both stopped working twice after a reboot until I put back the original files. I didn’t replace anything else, just the json files.

Not enough information to tell. Often it’s a power problem rather than anything you did.

While I don’t doubt your obvious technical expertise, I do doubt that it was a power issue because my server, comms equipment and both of the feeders are on a UPS and everything including the Raspberry’s has run without any problem whatever since I put back the original jsons.

Anyway, I have put the updated jsons on one of my RPi’s and we’ll see what happens.

Not a power outage but sagging voltage at the Pi end. Usually the first victim of that is the dongle / dump1090 wedging. There are few reasons other than hardware problems for an outright hang of dump1090.

Is that a true dual conversion UPS or a switched UPS? I witnessed one of those switched UPS in action, and the PC server continued to work perfectly, due to internal capacitors being sized properly.
But a small switch, powered by a wall transformer, had a full power outage (reboot) and a router had a only brown-out (locked up). I have added extra capacitors on the board of the switch and that solved the UPS power switching issues.
I don’t know what power supply you have on the Pi, and what capacity has… but is something to look into.

Didn’t delete the old… just did a replace… thinks worked seamlessly. which I did a quick before and after…

You make a valid point SoNIc, but I’m still not convinced by the power supply theory because I was running each Pi with just a dongle in early May and added an LNA to each Pi (and enabled bias-t) in June so the power requirements have been much higher since than they were when it happened.

The other thing is, my router and switches didn’t seem to be affected because according to the logs provided to me by the monitoring service I used at the time, availability of my web and email servers never changed.

Perhaps it was just a very strange coincidence that they were running perfectly before I put on the updated jsons and have been running perfectly ever since I put back the original ones.

Something else maybe an o/s update?

I will probably never know, unless it happens again…

I’ve copied the files now to the given directory under dump1090-fa/html/db
Two questions:

  • Do i have to restart dump1090?
  • Would it work with your customized Frontend (tar1090) as well?

Only modifying this folder /usr/share/dump1090-fa/html/db should really have no implications on the dump1090 process whatsoever.
But yeah it’s hard to say now :slight_smile:

Please read the path exactly. You are likely aware what html is? :innocent:

Anyway the database is only used by the webinterface running in your browser, not dump1090 itself.

And tar1090 uses the same database, so it’s perfectly compatible.