FlightAware Discussions

Sudden Loss of range


#1

Hi,

I recently resurrected my dead piaware (bad sd card), and the first week everything was great. I have suddenly lost a large amount of range for the last two days. It was a bit windy, but everything looks good. I am just wondering what could be wrong and how to troubleshoot without replacing parts. If a part is found to be bad, I am happy to replace it, but do not want to just start buying parts hoping it will replace it.

What should I check? I am unix proficient, so I do not mind SSHing into it. I am happy to install scripts or packages. I’d like to narrow the problem down and not just start replacing parts.

If anything the recent wind should have knocked down lots of leaves and increase the range.

I have the Orange FlightAware USB receiver and FlightAware filter, and an external antenna, about 50 feet off the ground.

I am also sending data to FR24.

Thanks in advance.


#2

Did you optimise the gain settings? If so, maybe you need to do it again.

The FA Antennas and connectors occasionally get water in them. Something else to check.


#3

Maybe some automatic FR24 update screwed up the gain setting :wink:

For sure check the gain.
Either check /etc/default/dump1090-fa if you installed dump1090-fa piaware.

If you used the piaware sd-card you need to run
piaware-config
and it will display the gain if any is set.
try
piaware-config rtlsdr-gain -10
piaware-config rtlsdr-gain 49.6
piaware-config rtlsdr-gain 40

for a start.

in both cases

service dump1090-fa restart

will activate the setting.

you can also check

journalctl -u dump1090-fa -e

to see which gain is actually being used.

There are a ton of threads on the subject and if you are unix proficient the manuals should be enough :slight_smile:


#4

more /etc/default/dump1090-fa

Generated automatically by fa_config_generator

This file will be overwritten on reboot.

DECODER_OPTIONS="–max-range 360"
NET_OPTIONS="–net --net-heartbeat 60 --net-ro-size 1000 --net-ro-interval 1 --net-http-port 0 --net-ri-port 0 --net-ro-port 30002 --net
-sbs-port 30003 --net-bi-port 30004,30104"
JSON_OPTIONS="–json-location-accuracy 2"
RECEIVER_OPTIONS="–net-bo-port 30005 --fix --device-index 0 --gain -10 --ppm 0"

piaware-config

allow-auto-updates yes # value set at /boot/piaware-config.txt:67
allow-manual-updates yes # value set at /boot/piaware-config.txt:71
allow-mlat yes # value set at /boot/piaware-config.txt:75
allow-modeac yes # value set at /boot/piaware-config.txt:79
image-type piaware # value set at /usr/share/piaware-support/piaware-image-config.txt:5
manage-config yes # value set at /usr/share/piaware-support/piaware-image-config.txt:4
rtlsdr-gain -10 # value set at /boot/piaware-config.txt:60
wired-network yes # value set at /boot/piaware-config.txt:27
wireless-network yes # value set at /boot/piaware-config.txt:33
wireless-password # value set at /boot/piaware-config.txt:49
wireless-ssid M69H3 # value set at /boot/piaware-config.txt:48

I applied the values. There was not change after the restart

I checked all connectors. Only one is outside. None have water in them.

If I understand your theory, FR24, might have changed a setting, which means if I reset everything it would restore. I recently restarted fresh and I was getting similar results before my SD card died.

Is there a good link to help tune the parameters? Unix is not a problem, but, gain, DBi, antennas is not my forte.

Mike


#5

gain is just like volume.

You need to make it loud enough that the receiver can hear it but not so loud that the close planes are too “loud”.

What do you mean you applied the values?
You need to test each gain for a day then check range stats on flightaware status page.

It seems you are running the sd-card image so you need to use

sudo piaware-config rtlsdr-gain 49.6

to change gain. (49.6 is the piaware default)
Restart the dump1090-fa service and then post the output of

journalctl -u dump1090-fa -e

It should show something like this:

Nov 04 23:28:02 pi dump1090-fa[27820]: Found Rafael Micro R820T tuner
Nov 04 23:28:02 pi dump1090-fa[27820]: rtlsdr: tuner gain set to 22.9 dB

This is a long thread about setting gain and installing graphs to check the changes.
(Optimize Gain - which would you chose)

But flightaware stats page is usually sufficient.

It also might just be a connection. Unscrewing and rescrewing all the connections should elminate that possibility.


#6

I adjust the gain setting to 49.6, I did used piaware-config rtlsdr-gain 49.6 to adjust the value. I tried other setting, without much change. I do not use sudo.

Nov 05 21:28:04 piaware dump1090-fa[19960]: Mon Nov 5 21:28:04 2018 UTC dump1090-fa 3.6.3 starting up.
Nov 05 21:28:04 piaware dump1090-fa[19960]: rtlsdr: using device #0: Generic RTL2832U OEM (Realtek, RTL2838UFA, SN 00000123)
Nov 05 21:28:04 piaware dump1090-fa[19960]: Found Rafael Micro R820T tuner
Nov 05 21:28:04 piaware dump1090-fa[19960]: rtlsdr: tuner gain set to 49.6 dB

Still no Change. I am setting up the graphs and reading the link about gain, and running the optimize gain python script as I type.

Is there any chance it is a hardware issue or the antenna or filter is possibly damaged?

I have checked all connections (unscrewed and screwed).

thanks for the help.


#7

What kind of antenna are you using, a commercial one?
Commercial antennas are sturdy if the connector is good then it’s likely the antenna is good.
The filter being damaged is unlikely, but you can just test without the filter and see if the reception improves.

The dongle preamplifier could possibly have quit on you.
But without another dongle to compare it to there is really no way to test it.

You could try without cable but then you probably don’t have the necessary adapters towards the antenna.

Such things are really hard to diagnose without some baseline to compare to or expensive testing equipment.
(If you don’t find anything maybe just buy a blue dongle or get the awesome rtl-sdr v3 with rtl LNA combination :wink: and yes that’s a shot in the dark)

Anything else that changed on Friday/Saturday? :stuck_out_tongue:
Maybe you got a new electrical appliance?
Did you touch the pi at all that day?
Was there thunder/lightning?


#8

Isn’t -10 the default value? That leads to a gain value higher than 49.6, due to a kind of bug, according to @obj


#9

The source code of piaware agrees with you:

                         {"rtlsdr-gain"           -type double -default -10}                                                       

Anyway no matter the range difference msears101 is experiencing should not be that much between -10 and 49.6

And yes defacto -10 is a higher gain setting than 49.6 (in practice it is around 55 i believe)


#10

I did try -10. I will go back to that when I am done troubleshooting. It was -10 when I started. I am looking for other things (maybe hardware or physical problem in cabling/connector/filter) that could cause this sudden drop in range.

Thanks all for the help.


#11

My Antenna is the 66cm one that flightaware sells on Amazon.

Nothing changed. It suspiciously looked like it happened at 00:00 UTC. I was away when it happened. There was no lightning only wind.

I think I might try upgrading the dongle. are these the two options – https://www.amazon.com/dp/B07J2RJQ9Z/ and https://www.amazon.com/dp/B0129EBDS2 that you are talking about? Is one better? If I am going to spend money to troubleshoot might as well get the higher performing one.

Thanks Wiedehopf for the insight and help


#12

The rtl one is only better if you also get their LNA (https://www.rtl-sdr.com/new-product-rtl-sdr-blog-1090-mhz-ads-b-lna/) which is extra money :frowning:

The blue dongle has an integrated LNA but the external one from rtl has better filtering and two stage amplification.
Also the external LNA you could install in a raintight enclosure close to the antenna.
But the more expensive combo should outperform even when you just install it indoors.
(And you of course hope it would being more expensive ;))

If you don’t want an external LNA the blue dongle is unbeatable. (you would probably still use the FA filter but you can try without and check which is better, will depend on the signals around you)


#13

I got the blue one from FA that has preamp and filtering. It worked great for me. I kept poking around with different ones, but that was still the best.

Eventually I have bought a $99 one (AirSpy Mini) and that finally got better results, mainly because of the better DAC. But also required extra amplification (so more money).


#14

Do I understand it correctly.? The RTL-sdr LNA requires power and it will get the power from their dongle?

So Here is my exact setup. I get an advantage from the filter. I assume it is because there are multiple high powered TV, radio, Cell all with in a mile from me. My setup is, Antenna, adapter, 10 ft cable, FA Filter, Orange FA dongle. The antenna is 5 ft off the peak of my roof. I have the tallest house around, so only some trees and the commercial antenna block me. Everything is mounted inside to the underside of my roof. Is it worth it to put the LNA outside when I only have a 10ft antenna extension cable?

Thanks everyone for the education. It was just plug and play and just worked before this.

Mike


#15

No that’s likely not worth it :wink:
I’m using mine on the inside of the roof as well.

Yes the LNA needs some power and that is fed through the coax (you need to enable it in software, there is a guide how to do it (https://www.rtl-sdr.com/getting-the-v3-bias-tee-to-activate-on-piaware-ads-b-images/))

Without power the LNA will block signals and you get literally no reception :slight_smile:

The blue stick already has an advantage over the orange stick regarding filtering: Like the orange stick the signal is amplified but then is filtered internally where the orange stick has no filter.

The filtering done by the rtl-sdr LNA is superior though and also the noise floor of the LNA is probably better. (very rough filtering comparison (Testing Signal Quality with Spectrum Analyzer?))

Note that i’m not sure if i get the extra performance because of the filtering or the LNA is just better.
Maybe a combination of both. But i do notice fainter signals can be detected.


#16

My maximum range fell off last March. I found it was caused by a kink in the feeding coax.


#17

So the winner is jonhawkes2030 > Water was the issue. I had the connector on the Antenna protected and though water could not have gotten in there, well it did. It was a nice day for a walk on the roof and just checked, there was water and my signals bounced back. THank you Jon (and everyone else).

I have ordered the Blue Pro stick. I will compare it the Orange pro stick with external filter and post the results for anyone that is curious.

dump1090-localhost-aircraft_message_rate-24h dump1090-localhost-local_rate-24h dump1090-localhost-aircraft-24h


#18

The external filter might still be beneficial with the blue stick :slight_smile:

Would you mind posting your signal graph as well?
Or
http://pi/dump1090-fa/data/stats.json
:wink:


#19

{
“latest”:{“start”:1541615794.3,“end”:1541615794.3,“local”:{“samples_processed”:0,“samples_dropped”:0,“modeac”:0,“modes”:0,“bad”:0,“unknown_icao”:0,“accepted”:[0,0],“strong_signals”:0},“remote”:{“modeac”:0,“modes”:0,“bad”:0,“unknown_icao”:0,“accepted”:[0,0]},“cpr”:{“surface”:0,“airborne”:0,“global_ok”:0,“global_bad”:0,“global_range”:0,“global_speed”:0,“global_skipped”:0,“local_ok”:0,“local_aircraft_relative”:0,“local_receiver_relative”:0,“local_skipped”:0,“local_range”:0,“local_speed”:0,“filtered”:0},“altitude_suppressed”:0,“cpu”:{“demod”:0,“reader”:0,“background”:0},“tracks”:{“all”:0,“single_message”:0},“messages”:0},
“last1min”:{“start”:1541615734.3,“end”:1541615794.3,“local”:{“samples_processed”:143917056,“samples_dropped”:0,“modeac”:0,“modes”:1427661,“bad”:910183,“unknown_icao”:504459,“accepted”:[11943,1076],“signal”:-7.4,“noise”:-21.2,“peak_signal”:-0.9,“strong_signals”:1312},“remote”:{“modeac”:0,“modes”:534,“bad”:0,“unknown_icao”:0,“accepted”:[534,0]},“cpr”:{“surface”:1,“airborne”:1368,“global_ok”:1305,“global_bad”:0,“global_range”:0,“global_speed”:0,“global_skipped”:1,“local_ok”:49,“local_aircraft_relative”:0,“local_receiver_relative”:0,“local_skipped”:15,“local_range”:0,“local_speed”:0,“filtered”:0},“altitude_suppressed”:0,“cpu”:{“demod”:14660,“reader”:5658,“background”:902},“tracks”:{“all”:9,“single_message”:3},“messages”:13553},
“last5min”:{“start”:1541615494.3,“end”:1541615794.3,“local”:{“samples_processed”:719978496,“samples_dropped”:0,“modeac”:0,“modes”:7109565,“bad”:4526857,“unknown_icao”:2509411,“accepted”:[67131,6166],“signal”:-7.2,“noise”:-20.9,“peak_signal”:-0.5,“strong_signals”:6863},“remote”:{“modeac”:0,“modes”:2889,“bad”:0,“unknown_icao”:0,“accepted”:[2889,0]},“cpr”:{“surface”:4,“airborne”:7933,“global_ok”:7597,“global_bad”:0,“global_range”:0,“global_speed”:0,“global_skipped”:9,“local_ok”:288,“local_aircraft_relative”:0,“local_receiver_relative”:0,“local_skipped”:52,“local_range”:0,“local_speed”:0,“filtered”:0},“altitude_suppressed”:0,“cpu”:{“demod”:73456,“reader”:28426,“background”:4623},“tracks”:{“all”:34,“single_message”:13},“messages”:76186},
“last15min”:{“start”:1541614894.3,“end”:1541615794.3,“local”:{“samples_processed”:2160066560,“samples_dropped”:0,“modeac”:0,“modes”:21238450,“bad”:13500948,“unknown_icao”:7488426,“accepted”:[228785,20291],“signal”:-6.6,“noise”:-20.3,“peak_signal”:-0.4,“strong_signals”:36727},“remote”:{“modeac”:0,“modes”:8091,“bad”:0,“unknown_icao”:0,“accepted”:[8091,0]},“cpr”:{“surface”:6,“airborne”:27545,“global_ok”:26549,“global_bad”:0,“global_range”:0,“global_speed”:0,“global_skipped”:20,“local_ok”:841,“local_aircraft_relative”:0,“local_receiver_relative”:0,“local_skipped”:161,“local_range”:0,“local_speed”:0,“filtered”:0},“altitude_suppressed”:0,“cpu”:{“demod”:221141,“reader”:86318,“background”:13760},“tracks”:{“all”:90,“single_message”:35},“messages”:257167},
“total”:{“start”:1541462434.2,“end”:1541615794.3,“local”:{“samples_processed”:366059061248,“samples_dropped”:0,“modeac”:0,“modes”:3763394551,“bad”:2409141367,“unknown_icao”:1340093381,“accepted”:[12982191,1177612],“signal”:-7.6,“noise”:-23.3,“peak_signal”:-0.4,“strong_signals”:1174745},“remote”:{“modeac”:0,“modes”:414633,“bad”:0,“unknown_icao”:0,“accepted”:[414633,0]},“cpr”:{“surface”:655,“airborne”:1649676,“global_ok”:1592016,“global_bad”:11,“global_range”:6,“global_speed”:2,“global_skipped”:1111,“local_ok”:43586,“local_aircraft_relative”:0,“local_receiver_relative”:0,“local_skipped”:14718,“local_range”:1,“local_speed”:24,“filtered”:0},“altitude_suppressed”:0,“cpu”:{“demod”:37537121,“reader”:13894732,“background”:1744114},“tracks”:{“all”:10903,“single_message”:6692},“messages”:14574436}
}

dump1090-localhost-signal-24h


#20

For the last 15 minutes that is 36727/(228785+20291) = 14.7 % of strong messages. (>-3dB, nearly too strong to be received hinting that you didn’t receive some stronger messages because the signal was too strong)

You should probably try 49.6 instead of -10 now for the gain :wink:
Probably higher message rate but not sure if it would cut range, probably not much if at all but hard to say without testing.

Oh and the red area in the Message Rate graph is kinda bogus, it represent the derivative of the messages > -3dB which is not that useful.
I’ve written a fix you can read about and download if you want:
(Optimize Gain - which would you chose)