Signal Level Randomly Changing

Hello All,

When I look in graphs1090, my signal level changes throughout the day. See screenshots below.

I knew that auto gain was introduced with Piaware 6. So, I disabled auto gain in my settings in /boot/piaware-config.txt and set the gain to 29.7. Prior to Piaware 6, I set the gain to 29.7 since that was the best for my indoor setup.

In the /boot/piaware-config.txt, I set the following to “no”:

  • adaptive-dynamic-range no
  • adaptive-burst no

When I run “sudo systemctl status dump1090-fa”, my gain is showing 29.7. When I run “piaware-config”, the rtlsdr-gain is showing 29.7. I’ve looked at the gain when the signal level was going up/down, and the gain was still showing 29.7.


  • Could the gain still be set to auto gain somehow? I could have missed putting something in the piaware-config.txt.
  • Is there something else that could be changing my signal level? This problem only started after I upgraded to Piaware 6.
  • Any thoughts on what else I should check?

Setup is indoor by a window:

  • Raspberry Pi 4
  • Uputronics 1090 Filter/Preamp
  • Piaware 6 image (not the add-on)
  • Flightaware Pro Plus (blue dongle)
  • 1090 MHz ADS-B Antenna - 66 cm / 26 in
  • 25 ft Low-Loss Coaxial Extension Cable


  • Gain = 29.7

The signal levels go down at night because there are less aircraft flying at night and generally less radio noise.
It looks like my setup with fixed gain.

Look at the exact time the signal drops. Does anything correspond to that time? I have one setup in my bedroom. The TV increase the noise levels significantly when it is on.
LED lights can also cause issues.

Yup. The signals at night definitely drop since there are less planes. My concern was really from the hours of 6a to about 4p. When I was on Piaware 5, the signal was much more stable during the same time frame. Also, my position counts are not consistent with other receivers that are within 10 miles. The screen shot below shows how erratic my position counts are for the last few weeks. I took down my setup on 11/10 to troubleshoot further, but I couldn’t find anything wrong.

I thought it could be something in my room that was causing the issue, but I don’t turn on the TV during the day.

1 Like

It is something like that for sure.

When you observe it start turning off everything electrical.

So either it’s 1090 MHz then you can only improve this by turning off the noise source.
If it’s strong interference causing the LNA to overload and work worse you can add a filter on the input.
To find that out … really you almost have to add a filter and see if it changes things.

Where is your antenna, the noise or interference is most likely coupling in via the antenna.
Doesn’t have to be your devices btw … could be a neighbor as well running something.

1 Like


I am copying below my July 2020 post, which proves that in a really noisy environment like mine, a filter connected before LNA is a must. In this case LNA is built into the ProStick.


My case is exactly opposite.
I see almost negligible aircraft when I remove filter and connect antenna directly to the ProStick Plus:

Every time I removed and inserted the Filter, I made sure that all connectors are fully tightened, so the drastic drop is not due to loose connection. Actually I have several Cell/Mobile phone companies antennas on my building as well as adjuscent buildings, which causes overload of the LNA of ProStick Plus, and its SAW chip being located after the LNA, cannot protect the LNA from overload.

I hope in next version of Pro Stick Plus which is due to be released shortly, they will either relocate the SAW filter between LNA and input SMA connector, or may be add one more SAW between SMA connector and LNA. Let us wait and see.

  1. Up to 21:20 EDT > Antenna connected to Pro Stick PLUS through FA Light Blue Filter
  2. From 21:20 to 21:50 EDT > Antenna connected to Pro Stick PLUS directly (Filter removed).
  3. From 21:50 to 22:00 EDT > Antenna connected to Pro Stick PLUS through FA Light Blue Filter
  4. From 22:00 to 22:25 EDT > Antenna connected to Pro Stick PLUS directly (Filter removed).
  5. From 22:25 EDT to end of graph > Antenna connected to Pro Stick PLUS through FA Light Blue Filter




1 Like

What about looking at the RF spectrum around 1090 to see if you have any interferences? The receivers with built-in filters are pretty useless for this but other receivers let you look at the RF spectrum in all its glory and you can pinpoint frequencies and times active maybe a bit easier? Especially handy as you try turning other devices on and off to see if spikes close to 1090 appear?

A pretty realistic, wide-band scan covering the entire bandwidth of RTL based dongles.

Spektrum - How-to Speedily Scan RF Noise in band 24MHz ~ 1800MHz


The results of scans are below:

The scan 1 shows RF noise picked by antenna and processed without any filter , The scans 2 & 3 were done with filters, and show how filters remove this noise.

Scan 1 of 3 - FA Antenna + Generic DVB-T (no internal or external filter)

Thumb-Generic DVB-T


Scan 2 of 3 - FA Antenna + ProStick Plus (Only Internal filter of ProStick Plus. No External filter)


Scan 3 of 3 - FA Antenna + ProStick Plus (with internal filter) + External Filter (FA Light Blue)


1 Like

Exactly! Thanks @abcd567! - Do you have a similar scan with the orange dongle?

Yes, but my location is Urban High Rise, with high RF noise. Most people will not have that bad noise at their location.

FA Antenna + Orange ProStick (No external Filter)



FA Antenna + Orange ProStick + FA Light Blue External Filter



1 Like

@wiedehopf @abcd567

My Uputronics 1090 filter is connected directly to the antenna. So, my current setup looks like:

Antenna => Uputronics => Coax => Pro Plus dongle

Should I connect the Uputronics directly to the blue dongle? Is this what you both mean by putting the filter before the LNA? Sorry, newb here.

My antenna is by the window. I have an indoor setup.

What exactly happens when the LNA overloads? My dump1090 service shutoff a couple times during the summer and didn’t restart. I only noticed that it wasn’t working when I got an automated email saying that my receiver was down. At the time, I also had the Pro stick (orange) dongle attached to the same Raspberry Pi that was also used to pick up UAT signals. The dump978 service was still active and didn’t shutdown even though the dump1090 stopped working.

I’ve run a scan in the past, and I have a cell tower near my home. After adding the Uputronics to my setup, I filtered out a lot of the noise. I’ll run this scan again when I see that that the signal is going up/down again.

Yeah it’s gonna probably some electric device / monitor whatever in the same room being switched on / off.

I was talking an extra filter.

Anyhow … i’d guess it’s just broad band interference you can’t do anything about besides keeping the device off or relocating the device or antenna.

What’s close to the antenna?
Could be USB3 … monitor cable … stuff.

The equipment that is near the antenna is a power strip surge protector. I plug my Raspberry Pi along with the Uputronics to that strip. The surge protector and Pi are about 2 - 3 feet from the antenna.

So add another filter before the blue dongle like this one?

Well those should emit relatively constant noise.

I’d guess other equipment in the same room.

You’d add it before the uputronics if you have super strong interference.
But it’s unlikely, interference you can’t filter is more likely in my opinion.

Best bet for this noise is some monitor cable or something else with broad band noise.
You have to find a correlation of something being on / off and the signal level graph …
Switch on everything in the room and see what the signal level graph does … once you have it misbehaving turn off stuff one by one and check when the signal goes back to how it’s supposed to look.

For the last several days, I’ve been checking in my room to see what could possibly be causing this issue. I noticed that my the signal drops when my work laptop is in the room. I took my laptop out of the room and my ADS-B signal increased. I did this several times to verify.

I thought the Uputronics would have filtered this out? I’m wondering if the Uputronics is broken since I have always worked in that room without issue.

The uputronics amp does have a filter but seems to be susceptible to interference. I use them but need a cavity filter on the antenna side to reduce interference.

That depends on what frequency the interference from you laptop is on.
I your laptop is generating interference at 1090MHz then it is acting as a jammer and this cannot be filtered out by your amp, as it is on the wanted frequency.

1 Like

I already explained (or so i thought) that there is a difference between unwanted signal in the band you’re trying to receive and unwanted signal outside that band.

If you have noise on 1090 MHz you can’t filter that out … the filter can only filter something that’s not in that frequency range (± 15 MHz) otherwise you’d filter what you want to receive.

Your laptop is just emitting broadband noise, likely from the display or USB.
Thus aircraft far away are “quieter” than the laptop and you can’t “hear” them anymore.
(laptop is drowning them out)

1 Like

Is the laptop running on battery power when you’re working in the room with the Pi, or is it connected to the AC mains power supply/charger?

Got it. That makes sense.

Yes. The laptop is connected to the wall outlet via a power brick.