FlightAware Discussions

SD card error, unallocated space

I have a new 32 gb sd card, when I install the Piaware 5.0 image the space is smaller between 95 and 150 Mb. I format the sd and come back with 32 gb of space, I install the piaware image it becomes small again, this is interfering with the data Mlat.

Access the manager and it appears 28 GB not allocated.

Does anyone know what’s going on?

New Pi images need to expand the file system

Either from the command line on the screen or via SSH run the following command;

sudo raspi-config (The default password is flightaware)
Select No. 6 Advanced options then A1

Reboot and full size should show.

If username needed to log in it is pi with password flightaware

Geoff

1 Like

There’s no need to manually expand the filesystem, this is done automatically on first boot.

If you’re inspecting the sdcard before it’s been booted once, that’s the problem. Try booting it once and look again.

If that’s not working correctly I’m not sure why. Does a standard Raspbian image correctly expand the filesystem on first boot? (It’s exactly the same logic)

1 Like

Been using Pi devices for various projects since the first Pi - never knew it automatically expanded the file system. Strange, get used to doing something and it becomes a habit, I still us dd to write my images :sunglasses:

Geoff

1 Like

I tried to do this, but the SD card is still 150 Mb and the SD card is 32 GB, I formatted it again, 32 GB appeared, I installed the Piaware 5.0 image again using balenaEtcher, when I do this it goes back to 150 mb.

pi@piaware:~ $ sudo raspi-config

Welcome to fdisk (util-linux 2.33.1).
Changes will remain in memory only, until you decide to write them.
Be careful before using the write command.

Command (m for help): Disk /dev/mmcblk0: 7.4 GiB, 7948206080 bytes, 15523840 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xeda531dc

Device Boot Start End Sectors Size Id Type
/dev/mmcblk0p1 8192 334116 325925 159.1M c W95 FAT32 (LBA)
/dev/mmcblk0p2 335872 15523839 15187968 7.2G 83 Linux

Command (m for help): Partition number (1,2, default 2):
Partition 2 has been deleted.

Command (m for help): Partition type
p primary (1 primary, 0 extended, 3 free)
e extended (container for logical partitions)
Select (default p): Partition number (2-4, default 2): First sector (2048-15523839, default 2048): Last sector, +/-sectors or +/-size{K,M,G,T,P} (335872-15523839, default 15523839):
Created a new partition 2 of type ‘Linux’ and of size 7.2 GiB.
Partition #2 contains a ext4 signature.

Command (m for help):
Disk /dev/mmcblk0: 7.4 GiB, 7948206080 bytes, 15523840 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xeda531dc

Device Boot Start End Sectors Size Id Type
/dev/mmcblk0p1 8192 334116 325925 159.1M c W95 FAT32 (LBA)
/dev/mmcblk0p2 335872 15523839 15187968 7.2G 83 Linux

Command (m for help): The partition table has been altered.
Syncing disks.

I tried and it didn’t change unfortunately, but thanks for the answer! I’m trying here Rs.
this happened with 5.0 when it was 4.0 the SD was normal.

Apologies if I am stating the obvious here but I hate to assume knowledge; are you aware that the Raspberry Pi images create two partitions?

One is FAT32 and on my PiAware system it is 253MB
The second partition is a Linux Ext4 and should be virtually the full SD card size.

Geoff

1 Like

Puzzled as to all that info under raspi-config

If I issue that command I get a menu appear then I have options to alter various configurations.

Mind you, I install the PiAware program onto a basic RaspberryPi image rather than use a PiAware image. Wouldn’t have thought that would make any difference to the raspi-config file though.

Geoff

1 Like

Unclear exactly what you did, but the Pi thinks this is a 8GB sdcard, not 32GB; and the second partition has been correctly expanded to take the full space of an 8GB sdcard.

What does df -h say?

(You may have a fake sdcard that’s misrepresenting the actual capacity)

1 Like

Didn’t know about partition! Now I understand, thanks for the explanation!

1 Like

I’m sorry I didn’t explain.
To test it I used an 8GB SD card, if it works I do it on 32GB.
I performed the command “sudo raspi-config” option 6 and A1.

About partition 1 being smaller, can this error appear in the anomaly?

“CPU load of 90% is fairly high. You might consider running lower programs on your Pi, or upgrading your Pi to a faster version such as the Pi 2.”

I’m lost.
Error

The boot partition is always that small.

Well it’s a slow RPi.
dump1090 has a function on the way to use less CPU on an old RPi.
But as far as i know it’s not yet released.

In the meantime i’d suggest using readsb instead of dump1090-fa:
Raspbian Lite: ADS B receiver · wiedehopf/adsb-wiki Wiki · GitHub

Or just turn down the gain, that will probably also reduce CPU use.

Am I correct to assume that the more aircraft traffic about then the busier the CPU will be?

I run PiAware on a zero, I am around 14 miles from Heathrow, aircraft regularly pass over at around 8000 feet (around 2400m) and my CPU is around 50%.

No special antenna, just stock item sits on a can by a window.

Shall try your readsb

Geoff

It depends a lot on the gain and the noise and all kinds of stuff.

Also it depends on the dump1090-fa version, the CPU increase came with an improvement introduced with 5.0

1 Like