FlightAware Discussions

Run from external hard drive?

Evening all,

Long time no speak - I’ve been off air for a while, looks like my SD card died!

Was looking at using one of the “Extended Life” SD cards - intended for constant r/w/rw (unlike standard SD cards, this is what kills them).
Then, spotted you can have the Pi use an external drive for the root…

Now have a 120gb 2.5" drive (from my old xbox 360) in a powered USB caddy.

I’ll be using this how-to linked below - anyone know of any issues with this?

learn.adafruit.com/external-dri … t/overview

Also, I’ll do a manual install of PiAware etc (or JP’s ADSBReciever scripts), on top of the Armbian image - im using the Orange Pi PC, but hopefully that wont have any issues.

NB - I’ve used ADSBR on the OPI succesfully for many months - the only change here is using the HDD rather than the SD.

Thoughts?

Recently I installed Armbian 5.25 on my Orange Pi PC.
It is available in 3 versions:
On main download page for Orange Pi PC: armbian.com/orange-pi-pc/
(1) Armbian_5.25_Orangepipc_Ubuntu_xenial_default_3.4.113_desktop (desktop)

On other download options & archieves page for Orange Pi PC: dl.armbian.com/orangepipc/
(2) Armbian_5.25_Orangepipc_Debian_jessie_default_3.4.113 (headless)
(3) Armbian_5.25_Orangepipc_Ubuntu_xenial_default_3.4.113 (headless)

I tried all 3 versions, finally settled for (3), although all three are more or less same.

WORKAROUND FOR ALL 3 VERSIONS

(1) Dump1090 Not Working:
to make dump1090-fa work, edit file rtl-sdr-blacklist.conf



sudo nano /etc/modprobe.d/rtl-sdr-blacklist.conf
#add following two lines to the file
blacklist dvb_usb_rtl2832u
blacklist dvb_usb

Ctrl+o (save), Ctrl+x (close file & nano editor)

sudo reboot


(2) Gmap Does Not Display as Lighttpd Does Not Work:
BEFORE installing dump1090-fa (with integral lighttpd), or dump1090-mutability + lighttpd, disable ramlog by changing ENABLED=true to ENABLED=false



sudo nano /etc/default/log2ram
# configuration values for the log2ram service
ENABLED=false
SIZE=50M
USE_RSYNC=false

Ctrl+o (save), Ctrl+x (close file & nano editor)

sudo reboot


Re booting from SD, but move root FS to the HDD, found this works, at least in Armbian Jessie…

nand-sata-install

dont know how or why yet, but it has a basic OS gui, and seems to be working!

Added for self / others reference

@abcd567 - hi again mate, been a while! :wink:

Has the OPi / PiAware / Mut etc changed all that much, as to require all this fixes?
I’m sure when I first set the OPI up (running from sd) many months ago, it was pretty straight forward?

I’ll look into this more once I get this HDD set up, and start installing scripts etc…

Hi mate!
The fix #1 (blacklist rtl) was always there, I think you fogot.

The fix #2 started recently and is for versions 5.24 & 5.25

I have run from external USB sticks and HDD’s (no SD card at all in the Pi - I realize you mentioned Orange Pi), however when doing so, MLAT completely blows up for some reason. I assume it’s due to the extra noise/chatter on the USB line and interrupts are going bonkers, but I’d love to see it work fully. Other then MLAT, it’s no problem whatsoever.

Hi Nitr0

Yes, sounds possible.

As you say tho, the OPI still uses the SD - purely for boot - but with data still going over the USB, that’s certainly a possibility.
In fact, I believe it’s power going over the usb that’s more likely to cause an issue - I have my HDD powered over an external supply, so maybe that’d be less issue?

We’ll find out! :slight_smile:

All up and running, using the basic piAware 3.5 package install.

All working so far - cant see range in the new SkyView UI, but looks about right from what I saw previously.

Minimal (if any) MLAT yet (after a few minutes). SkyView shows MLAT is synced, so we’ll see what happens after a day or so.

I’ll post any progress here… :slight_smile:

Be nice if an admin or one of our many gurus (@obj? :wink: ) could confirm whether or not running from a HDD could cause issues with MLAT?

ATB,

C

OK, range plot showed up - presumably once enough data available.

Also, now have MLAT showing…

https://docs.google.com/drawings/d/1VxN0bl4W4rahJfNzxroeEcGdakJUe2VZB3KvhuG8WbM/pub?w=960&h=720

It all depends on what it does to the USB bus, so I have no idea.
If you start dropping USB data from the dongle, that will affect mlat. If you don’t, it won’t.

After 24hours, my MLAT reports are around 30% of ADSB - dont know if that’s what we’d expect (more likely it depends on rig / location).

I’m pretty happy I’m not seeing an issue capturing MLAT data…

Overall, very impressed with how straightforward it’s been to get this running off an HDD - saving the issue of killing SD’s, and of course much larger capacity available pretty cheap.

(My main reason is to avoid failing SD’s, but the capacity might be a reason to use HDD for those who log all the data long term).

Would recommend! :slight_smile:

Great to see!
I tried both powered through the USB and through a powered hub and my MLAT blew up on every test (could see within 5 minutes, never got synced). I believe our systems were slightly different however - I was using a Pi3 with bootloader and filesystem all on HDD/Stick as a complete replacement for the SDCard, so no SDcard was inserted at all. I had a few posts about it 6 or so months ago with no conclusions, so it ended up in the been there, tried that and didn’t work pile. I really wanted to make another attempt using an SSD for low(er) power draw, but didn’t have any spares.

Keep us posted on the results.

PS: I think OBJ can wave his magical wand to check your site on his end to see if there is anything goofy looking with your MLAT - a look under the hood so to speak?

Sorry to hear you didnt have much joy with your HDD set up Nitr0…

Mines just a 120GB hdd taken from my old relligated-to-the-attic xbox 360, in a caddy I got for £6 on Amazon…
Although my dad said “what are you going to store on a 120gb hdd?” - for me the point is using physical platters rather than Sd :wink:

That, and the Nand-To-USB command in Armbian Jessie for oPi, and all is good :slight_smile:

@Obj - would that MLAT reception look “usual” to you / your tools?
Synced with c280 nearby stations…

C