FlightAware Discussions

RTL-SDR v3 / LNA

Hi all
pi3
setup my old rtlblogv3 dongle with triple filter amp set @ -10 when biastee switched on both dongle and filter/amp are hot so working
i get 500 messages
take out filter amp i get 1000 messages sec
i have tested both filter amps on main system both working fine with sep bias tee’s
2nd system tested with blogv3 dongle
nooelec smartee
fa pro stick with sep bias tee
im going mad what can be the problem dodgy connection perhaps

You’ve been on the forum long enough to know that automatic gain doesn’t actually work and rather sets maximum gain.

Gain of about 23 is appropriate for that combination.

Nobody here should use automatic gain, it’s just evil :rofl:

2 Likes

Its been couple months since i retired the blog dongle for airspy
my memory is bad after a day orso a real pain

1 Like

If you don’t have an LNA (external or builtin), then using -10 is the only proper setting as it’s the maximum gain.

I see, then try 23, should be a definite improvement.

With -10 and the rtl-sdr LNA the signal is just much too strong so you lose a lot of messages.

set to 28.0 exact same figures weird
going lower

Maybe you didn’t really change the gain?

piaware image and normal Raspbian is different in regards to how to set the gain.
For Beginners - How to Set / Change Gain

1 Like

ok set to 20.7 both aircraft and message 15% down

Try 30 then, i don’t know your setup.

I suppose one of your connectors you only use with the LNA could be RP-SMA or something like that.
(missing the central pin)

LOL no all got willys

● dump1090-fa.service - dump1090 ADS-B receiver (FlightAware customization)
Loaded: loaded (/lib/systemd/system/dump1090-fa.service; enabled; vendor preset: enabled)
Active: active (running) since Wed 2019-11-27 18:29:53 GMT; 3min 23s ago
Docs: https://flightaware.com/adsb/piaware/
Main PID: 1092 (dump1090-fa)
Tasks: 3 (limit: 2200)
Memory: 5.1M
CGroup: /system.slice/dump1090-fa.service
└─1092 /usr/bin/dump1090-fa --device-index 0 --gain -10 --ppm 0 --net-bo-port 30005 --max-range

My commands
sudo piaware-config rtlsdr-gain 20.7
Set rtlsdr-gain to 20.7 in /etc/piaware.conf:9
pi@raspberrypi:~/rtl_biast/build/src $ sudo service dump1090-fa stop && cd ~/rtl _biast/build/src && ./rtl_biast -b 1 && sudo service dump1090-fa start

So you are doing it wrong. Seems you are not on a piaware image.
For Beginners - How to Set / Change Gain

So you didn’t change anything. Read the link, the procedure is different depending on what install you have.

Ahh yes raspberry buster with piaware over top

Yes i know where ive gone wrong
thankyou all

Ahhhhh Bisto…
i even forgot to reapply filter/amp whilst adjusting tests jeez all working well now
fantastic help all

If you read RTL-SDR’s site:

In addition please remember that this is a high gain LNA. It is expected to be used at the antenna side, with some 3+ db loss expected on the coax. However, if desired, it can still be used on the receiver side. If used on the receiver side or with a low loss run of coax, you will need to tune the RF gain on the RTL-SDR dongle. By default most software sets the RF gain to maximum. We recommend turning the RTL-SDR RF gain down to about 32 dB if connecting it directly to the dongle, otherwise the high input power may overload the dongle causing poor performance.

Personally, I found 8dB attenuation between the amp and dongle to be about right.

For me this triple filtered amp did not work as expected.

I had a working station built with a FA Orange Stick (amp only, no filter) + FA Filter (LC-type, not a saw filter) working fine on the antenna foot (2meters of cable) and wanted to move the Raspberry + Dongle down from the attic.

Using the RTL-SDR amp I had a sensible loss of messages/airplanes. When I increase the gain strong sinals were saturated. If I decrease the gain I lose range (and messages as well).

That was a no go for me, kept the rasp on the attic and tried to shield everything agaist ESD (my original source of problem).

I live near a dozen of FM towers, nothing works here without filters, event VHF radios requires filters to work.

Regards.