RF input gain stage adjustment

I have acquired an antenna that comes with a warning:
Please note: when using low loss setups the high gain of this antenna may lead to an overload of your dongle RF input stage. In this case the RF gain of the dongle has to be reduced. Very short cables may lead to deterioration of reception quality.

PiAware 3 Advanced Configuration says:

Setting name         Possible values                                      Default value
rtlsdr-gain          a numeric gain value in dB, or "-10" for AGC         -10

I assume AGC means Automatic gain control.
Is my assumptions correct?
Is the AGC good enough that I do not need to worry about overloading my RTL2832/R820T dongle?
If not what actions must be taken (i.e. how should I proceed) to adjust gain settings to avoid overloading?

piaware-config rtlsdr-gain -99
# Wait for messages and check (with what command?), if not close to limit increase 1 dB
piaware-config rtlsdr-gain -98
# Wait for messages and check, repeat until best setting found?

Yes and no. AGC is automatic gain control.
It doesn’t work for ADS-B signals. They vary too much too quickly.
200-500W pumping out for a millisecond or so. One could be overhead and another could be 200NM away. I see 200-300 aircraft at a time.

(1) How many dB is the gain of your antenna?
(2) If you use a RTL2832/R820T dongle WITHOUT a built-in or external amplifier, no need to worry too much about gain. Set its gain first to 49.6, then lower to 44.5, and again to 42.1. Compare the results. Most likely one of these settings will give you good performance.

Thanks to both of you!

(1) Maybe this image answer your question? 22.57dB?
If not, I have to be honest, I am not sure, RF-stuff is not my strongest side. It is a 1090 MHz Active PCB antenna, the page has 6 references to dB and the whole thing confuses me:

low noise amplifier with a gain of 20 to 30 dB
this amplifier, with noise figure of 0.8 dB and 30 dB of gain
shows a greater than 35 dB rejection frequencies outside the SAW 30 MHz bandwidth filter
total measured noise figure NF is 1.1 dB for an overall gain of 22 dB
It should be noted that the SDR tuner gain has been reduced down to 43 dB instead of the 49 dB automatic gain.
We can see that the 10 dB additional losses of the active antenna coaxial cable are far outweighed, especially as the antenna without the LNA has only 2 dBi gain, 6 fewer than collinear.

(2) I use NooElec NESDR SMArt. As far as I can tell it has no built-in or extarnal amplifier.
What do you mean with compare the results, as in: how do I compare the results? “Whoops to much gain”, SDR-dongle fried, replace, try again. I want to avoid the last thing… :laughing:

i doubt you will fry anything.

what they mean it will become deaf because there is so much signal, think of it along the lines of playing music so loud its saturated your ear drums and trying to have a conversation with someone in the same room. Not happening.

yet turn the volume down on the music (gain on the dongle) and you can listen to the music and hold a conversation.

So basically keep reducing the gain until the message rate starts to drop and then back a little and that will be about right.

So you are using “f5ann active pcb antenna” which has a built-in 20 to 30 dB amplifier and a 1090 mhz SAW filter.

The graph shows 22.5 dB gain at 1090 Mhz.

You need to reduce gain considerably. To what level depends on amount of RF noise (cell phone, etc) at your location.

You have to try different gain values till you find the best, as suggested by theresjam above. Others have reported using gain values as low as 28 and as high as 45, but each system and location is unique. Trial and error is the practical solution. Alternatively run script for gain setting optimization:

Gain Adjustment…

Thanks! :smiley:

I am running the Piaware img (SD card). Is running this command only enough to change the gain?

piaware-config rtlsdr-gain 49.6

or is some sort of dump1090 restart required?
or even reboot the Raspberry Pi after making changes to ensure that all configuration changes take effect? As the configuring your PiAware 3 page says.

I continued reading and found it (Source abcd567):

sudo systemctl restart dump1090-fa