Raspberry Pi2 MLAT problem


#1

Hi,

I have Pi2 with Raspbian Jessie and Piaware 3.5.3. MLAT on it hasn’t been working for quite sometime. When the problem occurred, I read that it is to do with Pi2. I did try a few fixes that were suggested on the forum but no joy.

I recently borrowed Pi3 to test it out. Took the current SD card from my Pi2 and used it with Pi3 but the problem didn’t go away.

Any suggestions on whether it could be fixed without reflashing the SD card? Preferably on Pi2.


#2

What are the error messages?
They may point to the problem being with the Dongle or the Internet connection.

I have an RPI2 that has been running well for 2 years.
https://flightaware.com/adsb/stats/user/jonhawkes2030#stats-17245
It uses a ModeSBeast, not the RTL-SDR dongle, however, that would only make a difference if the dongle is the issue.


#3

It says “local clock source is unstable”. It’s a dongle and has been working fine since I installed it almost a year ago.


#4

I think that is a problem with the local clock in the dongle. Which model/brand dongle are you using?

Could it be getting too hot? Does it happen during a hot time of the day?
Have you tried a different dongle?


#5

I have another dongle, will check with that. It just says DVB-T+DAB+FM. No, it doesn’t feel hot and it’s like this for quite sometime.


#6

Unfortunately, the issues remain even after changing the dongle.


#7

Have you worked through this MLAT Anomalies post about the Pi2 and Kernel versions? I had something similar and downgraded to v4.4. as above and everything was fine.


#8

Thanks! I will try downgrading to v.4.4. :+1:


#9

For some reason the latest OS kernel has a problem with the USB packets being ordered in the wrong way on Raspberry pi 2 boards. The old OS didn’t have this problem on Raspberry pi 2 and the Raspberry pi 3 boards never had this problem. This fix is to install the older software that doesn’t have the USB problem.

If you are having MLAT timing problem on Raspberry pi 3 then it might be another issue. We have noticed that some USB cables can cause dropped packets which will mess up the timing. Also not have a good power supply causes some timing issues.


#10

Thanks David!

As you can see from the screenshot, I have the old kernel. From “older software” you mean to reinstall older version of Piaware? If yes, can you please provide a link to it? I would prefer not to reflash the SD card as I have a few other feeding software installed on it as well.
58

Had the same problem on Pi3 when I used this SD card in it. Otherwise, with a fresh install Pi3 works fine.