FlightAware Discussions

Problem fetching data from dumo1090

For a while now I have been getting this error trying to access Skyaware via local web browser on multiple machines/devices across my network.

Capture

I know my RPi is communicating with Flightaware because my Flightaware page shows it is connected and I can send commands from the web interface to it. If I reboot the device, then I can access the page no problem. But after some random period of time, it is like the Skyaware page becomes unresponsive and back to the error. Also should note it also does not let me SSH in to it when this happens. My only option is to use the web interface on FA to send a command to restart it.

So I re-imaged the whole things last night with the latest 3.8.0 sd card image from this site. Fresh clean install, everything working! This morning check, back to the same error message and it is still connected. I have no clue what to do at this point to view Skyaware. Ideas?

Maybe it is changing the IP address?

Don’t think so… I have it set to a static address using Mac address IP binding. I can see the ip address is correct on the FA page and through my router.

Hate to keep saying it, but swap out your PSU and see how it goes.
A soft PSU (working, but putting out low voltage) can appear to work fine, but give the symptoms like you describe.

This points to a network problem, whatever the nature is.
Use Ctrl-F5 next time and probably you aren’t reaching the device at all.

Really hard to tell.
Anything in particular set in your piaware-config?

I’d probably make the systemd journal permanent and check the journal after the reboot.

Restart it so you can ssh in then inspect /var/log/syslog for any clues.

A friend of mine was experiencing this problem but in that case the unit would go offline completely.

I was initially thinking a network problem, but I can ping the IP of the RPi and after reboot it works fine. It is something to do with the web service running I am guessing, almost like it is sleeping. The PSU I am using came with the RPi kit when I got it and nothing else is consuming power off it. CPU utilization is very low as I do not have that much air traffic in my area. Also tried the Ctrl-F5 and no change.

I will have to try the journal after reboot that was mentioned, just need to figure out how to do this since I am very novice with the RPi and often follow procedures off this forum to make things work :slight_smile:

Only thing I can think of that I did with this install was added ADSBxchange feed through their process. Would that be causing Skyaware to not work?

if you can’t SSH either … that’s a very strange problem.
you have graphs running by chance? (https://github.com/wiedehopf/graphs1090#graphs1090)
maybe it’s running out of memory for some reason?
you could check a couple of hours after rebooting it with something like htop and see if anything is using too much memory.

apart from checking the logs i wouldn’t know where to start.

I’m familiar with the script and it shouldn’t cause any issues.

I have installed the graphs. We will see what I see tomorrow. Thanks for the suggestion.